[package] add kmod-swconfig and kmod-swich-ip175c
[openwrt.git] / package / kernel / modules / hwmon.mk
index f259a7af93a455a21ebff453a102a6fa01ece528..1e97c3733a075dbf66f548cef65c334b3ffb36bc 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006,2007 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -26,13 +26,18 @@ endef
 $(eval $(call KernelPackage,hwmon-core))
 
 
-define KernelPackage/hwmon-lm75
+define AddDepends/hwmon
   SUBMENU:=$(HWMON_MENU)
+  DEPENDS:=kmod-hwmon-core $(1)
+endef
+
+
+define KernelPackage/hwmon-lm75
   TITLE:=LM75 monitoring support
-  DEPENDS:=kmod-hwmon-core +kmod-i2c-core
   KCONFIG:=CONFIG_SENSORS_LM75
   FILES:=$(LINUX_DIR)/drivers/hwmon/lm75.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,60,lm75)
+  $(call AddDepends/hwmon,+kmod-i2c-core)
 endef
 
 define KernelPackage/hwmon-lm75/description
@@ -43,12 +48,11 @@ $(eval $(call KernelPackage,hwmon-lm75))
 
 
 define KernelPackage/hwmon-lm77
-  SUBMENU:=$(HWMON_MENU)
   TITLE:=LM77 monitoring support
-  DEPENDS:=kmod-hwmon-core +kmod-i2c-core
   KCONFIG:=CONFIG_SENSORS_LM77
   FILES:=$(LINUX_DIR)/drivers/hwmon/lm77.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,60,lm77)
+  $(call AddDepends/hwmon,+kmod-i2c-core)
 endef
 
 define KernelPackage/hwmon-lm77/description
@@ -57,13 +61,13 @@ endef
 
 $(eval $(call KernelPackage,hwmon-lm77))
 
+
 define KernelPackage/hwmon-lm90
-  SUBMENU:=$(HWMON_MENU)
   TITLE:=LM90 monitoring support
-  DEPENDS:=kmod-hwmon-core +kmod-i2c-core
   KCONFIG:=CONFIG_SENSORS_LM90
   FILES:=$(LINUX_DIR)/drivers/hwmon/lm90.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,60,lm90)
+  $(call AddDepends/hwmon,+kmod-i2c-core)
 endef
 
 define KernelPackage/hwmon-lm90/description
@@ -72,10 +76,9 @@ endef
 
 $(eval $(call KernelPackage,hwmon-lm90))
 
+
 define KernelPackage/hwmon-pc87360
-  SUBMENU:=$(HWMON_MENU)
   TITLE:=PC87360 monitoring support
-  DEPENDS:=kmod-hwmon-core @TARGET_x86
   KCONFIG:= \
        CONFIG_SENSORS_PC87360 \
        CONFIG_HWMON_VID
@@ -83,6 +86,7 @@ define KernelPackage/hwmon-pc87360
        $(LINUX_DIR)/drivers/hwmon/hwmon-vid.$(LINUX_KMOD_SUFFIX) \
        $(LINUX_DIR)/drivers/hwmon/pc87360.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,50,hwmon-vid pc87360)
+  $(call AddDepends/hwmon,@TARGET_x86)
 endef
 
 define KernelPackage/hwmon-pc87360/description
@@ -91,17 +95,17 @@ endef
 
 $(eval $(call KernelPackage,hwmon-pc87360))
 
+
 define KernelPackage/hwmon-w83627hf
-  SUBMENU:=$(HWMON_MENU)
   TITLE:=Winbond W83627HF monitoring support
-  DEPENDS:=kmod-hwmon-core @TARGET_x86||TARGET_rdc
   KCONFIG:= \
        CONFIG_SENSORS_W83627HF \
        CONFIG_HWMON_VID
   FILES:= \
        $(LINUX_DIR)/drivers/hwmon/hwmon-vid.$(LINUX_KMOD_SUFFIX) \
        $(LINUX_DIR)/drivers/hwmon/w83627hf.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,50,hwmon-vid w83627h)
+  AUTOLOAD:=$(call AutoLoad,50,hwmon-vid w83627hf)
+$(call AddDepends/hwmon,@TARGET_rdc||TARGET_x86)
 endef
 
 define KernelPacakge/hwmon-w83627hf/description