package/kernel: move PCMCIA modules to their own file & submenu
[openwrt.git] / package / kernel / modules / crypto.mk
index 879fa969f96dc6d1d551ee183a3559ad59625c34..3f9259bf3c0df4ca36f3d113abca21260d4444d9 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -56,14 +56,14 @@ endef
 $(eval $(call KernelPackage,crypto-core))
 
 
-define KernelPackage/crypto/Depends
+define AddDepends/crypto
   SUBMENU:=$(CRYPTO_MENU)
   DEPENDS:=kmod-crypto-core $(1)
 endef
 
 
 define KernelPackage/crypto-hw-padlock
-$(call KernelPackage/crypto/Depends,)
+$(call AddDepends/crypto,)
   TITLE:=VIA PadLock ACE with AES/SHA hw crypto module
   KCONFIG:= \
        CONFIG_CRYPTO_HW=y \
@@ -80,7 +80,7 @@ $(eval $(call KernelPackage,crypto-hw-padlock))
 
 
 define KernelPackage/crypto-hw-geode
-$(call KernelPackage/crypto/Depends,)
+$(call AddDepends/crypto,)
   TITLE:=AMD Geode hardware crypto module
   KCONFIG:= \
        CONFIG_CRYPTO_HW=y \
@@ -93,10 +93,11 @@ $(eval $(call KernelPackage,crypto-hw-geode))
 
 
 define KernelPackage/crypto-hw-hifn-795x
-$(call KernelPackage/crypto/Depends,+kmod-crypto-des @!TARGET_ubicom32)
+$(call AddDepends/crypto,+kmod-crypto-des @!TARGET_ubicom32)
   TITLE:=HIFN 795x crypto accelerator
   KCONFIG:= \
        CONFIG_CRYPTO_HW=y \
+       CONFIG_HW_RANDOM=y \
        CONFIG_CRYPTO_DEV_HIFN_795X \
        CONFIG_CRYPTO_DEV_HIFN_795X_RNG=y
   FILES:=$(LINUX_DIR)/drivers/crypto/hifn_795x.$(LINUX_KMOD_SUFFIX)
@@ -107,7 +108,7 @@ $(eval $(call KernelPackage,crypto-hw-hifn-795x))
 
 
 define KernelPackage/crypto-hw-ixp4xx
-$(call KernelPackage/crypto/Depends,@TARGET_ixp4xx +kmod-crypto-des +kmod-crypto-authenc)
+$(call AddDepends/crypto,@TARGET_ixp4xx +kmod-crypto-des +kmod-crypto-authenc)
   TITLE:=Intel IXP4xx hardware crypto module
   KCONFIG:= \
        CONFIG_CRYPTO_HW=y \
@@ -124,7 +125,7 @@ $(eval $(call KernelPackage,crypto-hw-ixp4xx))
 
 
 define KernelPackage/crypto-hw-ppc4xx
-$(call KernelPackage/crypto/Depends,@TARGET_ppc40x||TARGET_ppc44x)
+$(call AddDepends/crypto,@TARGET_ppc40x||TARGET_ppc44x)
   TITLE:=AMCC PPC4xx hardware crypto module
   KCONFIG:= \
        CONFIG_CRYPTO_HW=y \
@@ -141,14 +142,14 @@ $(eval $(call KernelPackage,crypto-hw-ppc4xx))
 
 
 define KernelPackage/crypto-aes
-$(call KernelPackage/crypto/Depends,)
+$(call AddDepends/crypto,)
   TITLE:=AES cipher CryptoAPI module
   KCONFIG:=CONFIG_CRYPTO_AES CONFIG_CRYPTO_AES_586
   FILES:=$(LINUX_DIR)/crypto/aes$(AES_SUFFIX).$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,09,aes$(AES_SUFFIX))
 endef
 
-define KernelPackage/crypto-aes/x86-2.6
+define KernelPackage/crypto-aes/x86
   FILES+=$(LINUX_DIR)/arch/x86/crypto/aes-i586.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,09,aes$(AES_SUFFIX) aes-i586)
 endef
@@ -157,7 +158,7 @@ $(eval $(call KernelPackage,crypto-aes))
 
 
 define KernelPackage/crypto-arc4
-$(call KernelPackage/crypto/Depends,)
+$(call AddDepends/crypto,)
   TITLE:=ARC4 (RC4) cipher CryptoAPI module
   KCONFIG:=CONFIG_CRYPTO_ARC4
   FILES:=$(LINUX_DIR)/crypto/arc4.$(LINUX_KMOD_SUFFIX)
@@ -168,7 +169,7 @@ $(eval $(call KernelPackage,crypto-arc4))
 
 
 define KernelPackage/crypto-authenc
-$(call KernelPackage/crypto/Depends,)
+$(call AddDepends/crypto,)
   TITLE:=Combined mode wrapper for IPsec
   KCONFIG:=CONFIG_CRYPTO_AUTHENC
   FILES:=$(LINUX_DIR)/crypto/authenc.$(LINUX_KMOD_SUFFIX)
@@ -178,7 +179,7 @@ endef
 $(eval $(call KernelPackage,crypto-authenc))
 
 define KernelPackage/crypto-des
-$(call KernelPackage/crypto/Depends,)
+$(call AddDepends/crypto,)
   TITLE:=DES/3DES cipher CryptoAPI module
   KCONFIG:=CONFIG_CRYPTO_DES
   FILES:=$(LINUX_DIR)/crypto/des$(DES_SUFFIX).$(LINUX_KMOD_SUFFIX)
@@ -189,7 +190,7 @@ $(eval $(call KernelPackage,crypto-des))
 
 
 define KernelPackage/crypto-hmac
-$(call KernelPackage/crypto/Depends,)
+$(call AddDepends/crypto,)
   TITLE:=HMAC digest CryptoAPI module
   KCONFIG:=CONFIG_CRYPTO_HMAC
   FILES:=$(LINUX_DIR)/crypto/hmac.$(LINUX_KMOD_SUFFIX)
@@ -200,7 +201,7 @@ $(eval $(call KernelPackage,crypto-hmac))
 
 
 define KernelPackage/crypto-md5
-$(call KernelPackage/crypto/Depends,)
+$(call AddDepends/crypto,)
   TITLE:=MD5 digest CryptoAPI module
   KCONFIG:=CONFIG_CRYPTO_MD5
   FILES:=$(LINUX_DIR)/crypto/md5.$(LINUX_KMOD_SUFFIX)
@@ -211,7 +212,7 @@ $(eval $(call KernelPackage,crypto-md5))
 
 
 define KernelPackage/crypto-michael-mic
-$(call KernelPackage/crypto/Depends,)
+$(call AddDepends/crypto,)
   TITLE:=Michael MIC keyed digest CryptoAPI module
   KCONFIG:=CONFIG_CRYPTO_MICHAEL_MIC
   FILES:=$(LINUX_DIR)/crypto/michael_mic.$(LINUX_KMOD_SUFFIX)
@@ -222,7 +223,7 @@ $(eval $(call KernelPackage,crypto-michael-mic))
 
 
 define KernelPackage/crypto-sha1
-$(call KernelPackage/crypto/Depends,)
+$(call AddDepends/crypto,)
   TITLE:=SHA1 digest CryptoAPI module
   KCONFIG:=CONFIG_CRYPTO_SHA1
   FILES:=$(LINUX_DIR)/crypto/sha1$(SHA1_SUFFIX).$(LINUX_KMOD_SUFFIX)
@@ -233,7 +234,7 @@ $(eval $(call KernelPackage,crypto-sha1))
 
 
 define KernelPackage/crypto-misc
-$(call KernelPackage/crypto/Depends,)
+$(call AddDepends/crypto,)
   TITLE:=Other CryptoAPI modules
   KCONFIG:= \
        CONFIG_CRYPTO_ANUBIS \
@@ -251,6 +252,7 @@ $(call KernelPackage/crypto/Depends,)
        CONFIG_CRYPTO_TEA \
        CONFIG_CRYPTO_TGR192 \
        CONFIG_CRYPTO_TWOFISH \
+       CONFIG_CRYPTO_TWOFISH_COMMON \
        CONFIG_CRYPTO_TWOFISH_586 \
        CONFIG_CRYPTO_WP512
   FILES:= \
@@ -273,14 +275,19 @@ define KernelPackage/crypto-misc/2.6
        $(LINUX_DIR)/crypto/camellia.$(LINUX_KMOD_SUFFIX) \
        $(LINUX_DIR)/crypto/crc32c.$(LINUX_KMOD_SUFFIX) \
        $(LINUX_DIR)/crypto/fcrypt.$(LINUX_KMOD_SUFFIX) \
-       $(LINUX_DIR)/crypto/tgr192.$(LINUX_KMOD_SUFFIX)
+       $(LINUX_DIR)/crypto/tgr192.$(LINUX_KMOD_SUFFIX) \
+       $(LINUX_DIR)/crypto/twofish_common.$(LINUX_KMOD_SUFFIX)
+endef
+
+define KernelPackage/crypto-misc/x86
+  FILES+=$(LINUX_DIR)/arch/x86/crypto/twofish-i586.$(LINUX_KMOD_SUFFIX)
 endef
 
 $(eval $(call KernelPackage,crypto-misc))
 
 
 define KernelPackage/crypto-ocf
-$(call KernelPackage/crypto/Depends,@!TARGET_uml +@OPENSSL_ENGINE)
+$(call AddDepends/crypto,@!TARGET_uml +@OPENSSL_ENGINE)
   TITLE:=OCF modules
   KCONFIG:= \
        CONFIG_OCF_OCF \
@@ -303,7 +310,7 @@ $(eval $(call KernelPackage,crypto-ocf))
 
 
 define KernelPackage/crypto-null
-$(call KernelPackage/crypto/Depends,)
+$(call AddDepends/crypto,)
   TITLE:=Null CryptoAPI module
   KCONFIG:=CONFIG_CRYPTO_NULL
   FILES:=$(LINUX_DIR)/crypto/crypto_null.$(LINUX_KMOD_SUFFIX)
@@ -314,7 +321,7 @@ $(eval $(call KernelPackage,crypto-null))
 
 
 define KernelPackage/crypto-test
-$(call KernelPackage/crypto/Depends,)
+$(call AddDepends/crypto,)
   TITLE:=Test CryptoAPI module
   KCONFIG:=CONFIG_CRYPTO_TEST
   FILES:=$(LINUX_DIR)/crypto/tcrypt.$(LINUX_KMOD_SUFFIX)