ath9k: fix various aggregation related race conditions
[openwrt.git] / package / kernel / modules / crypto.mk
index fa2ddbc2117ab8106bc749c80753a4649544f3bb..3be3afdcaa212c94e059ed1524a01414c46b9f66 100644 (file)
@@ -22,9 +22,9 @@ SHA256_SUFFIX:=$(CRYPTO_GENERIC)
 SHA512_SUFFIX:=$(CRYPTO_GENERIC)
 
 CRYPTO_MODULES = \
-       ALGAPI=crypto_algapi \
+       $(if $(filter 1,$(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.28)),ALGAPI2,ALGAPI)=crypto_algapi \
        AEAD2=aead \
-       PCOMP=pcompress \
+       $(if $(filter 1,$(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.36)),PCOMP2,PCOMP)=pcompress \
        BLKCIPHER2=crypto_blkcipher \
        HASH2=crypto_hash \
        MANAGER2=cryptomgr \
@@ -267,7 +267,8 @@ define KernelPackage/crypto-misc
        $(LINUX_DIR)/crypto/sha256$(SHA256_SUFFIX).ko \
        $(LINUX_DIR)/crypto/sha512$(SHA512_SUFFIX).ko \
        $(LINUX_DIR)/crypto/tea.ko \
-       $(LINUX_DIR)/crypto/twofish.ko \
+       $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),le,2.6.35)),,$(LINUX_DIR)/crypto/twofish.ko) \
+       $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.36)),,$(LINUX_DIR)/crypto/twofish_generic.ko) \
        $(LINUX_DIR)/crypto/wp512.ko
   $(call AddDepends/crypto)
 endef
@@ -356,3 +357,20 @@ endef
 
 $(eval $(call KernelPackage,crypto-test))
 
+
+define KernelPackage/crypto-xts
+  TITLE:=XTS cipher CryptoAPI module
+  KCONFIG:= \
+       CONFIG_CRYPTO_GF128MUL \
+       CONFIG_CRYPTO_XTS
+  FILES:= \
+       $(LINUX_DIR)/crypto/xts.ko \
+       $(LINUX_DIR)/crypto/gf128mul.ko
+  AUTOLOAD:=$(call AutoLoad,09, \
+       gf128mul \
+       xts \
+  )
+  $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-xts))