package/kernel: move PCMCIA modules to their own file & submenu
[openwrt.git] / package / kernel / modules / block.mk
index 85a440aa5e4050a2bfe38199cb93d917cc5edcb3..f1074251abb41c427c479dce2f0f4daa989f4c86 100644 (file)
@@ -7,6 +7,21 @@
 
 BLOCK_MENU:=Block Devices
 
+define KernelPackage/aoe
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=ATA over Ethernet support
+  KCONFIG:=CONFIG_ATA_OVER_ETH
+  FILES:=$(LINUX_DIR)/drivers/block/aoe/aoe.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,30,aoe)
+endef
+
+define KernelPackage/aoe/description
+  Kernel support for ATA over Ethernet
+endef
+
+$(eval $(call KernelPackage,aoe))
+
+
 define KernelPackage/ata-core
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Serial and Parallel ATA support
@@ -39,35 +54,6 @@ endef
 
 $(eval $(call KernelPackage,ata-ahci))
 
-define KernelPackage/ata-sil
-$(call AddDepends/ata,)
-  TITLE:=Silicon Image SATA support
-  KCONFIG:=CONFIG_SATA_SIL
-  FILES:=$(LINUX_DIR)/drivers/ata/sata_sil.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,41,sata_sil,1)
-endef
-
-define KernelPackage/ata-sil/description
- Support for Silicon Image Serial ATA controllers.
-endef
-
-$(eval $(call KernelPackage,ata-sil))
-
-
-define KernelPackage/ata-sil24
-$(call AddDepends/ata,)
-  TITLE:=Silicon Image 3124/3132 SATA support
-  KCONFIG:=CONFIG_SATA_SIL24
-  FILES:=$(LINUX_DIR)/drivers/ata/sata_sil24.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,41,sata_sil24,1)
-endef
-
-define KernelPackage/ata-sil24/description
- Support for Silicon Image 3124/3132 Serial ATA controllers.
-endef
-
-$(eval $(call KernelPackage,ata-sil24))
-
 
 define KernelPackage/ata-artop
 $(call AddDepends/ata,)
@@ -83,52 +69,6 @@ endef
 
 $(eval $(call KernelPackage,ata-artop))
 
-define KernelPackage/ata-octeon-cf
-$(call AddDepends/ata,@TARGET_octeon)
-  TITLE:=Octeon Compact Flash support
-  KCONFIG:=CONFIG_PATA_OCTEON_CF
-  FILES:=$(LINUX_DIR)/drivers/ata/pata_octeon_cf.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,41,pata_octeon_cf,1)
-endef
-
-define KernelPackage/ata-octeon-cf/description
-  Octeon Compact Flash support.
-endef
-
-$(eval $(call KernelPackage,ata-octeon-cf))
-
-
-define KernelPackage/ata-ixp4xx-cf
-$(call AddDepends/ata,@TARGET_ixp4xx)
-  TITLE:=IXP4XX Compact Flash support
-  KCONFIG:=CONFIG_PATA_IXP4XX_CF
-  FILES:=$(LINUX_DIR)/drivers/ata/pata_ixp4xx_cf.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,41,pata_ixp4xx_cf,1)
-endef
-
-define KernelPackage/ata-ixp4xx-cf/description
- IXP4XX Compact Flash support.
-endef
-
-$(eval $(call KernelPackage,ata-ixp4xx-cf))
-
-define KernelPackage/ata-rb532-cf
-$(call AddDepends/ata,@TARGET_rb532 @BROKEN)
-  TITLE:=RB532 Compact Flash support
-  KCONFIG:= \
-       CONFIG_PATA_PLATFORM \
-       CONFIG_PATA_RB532
-  FILES:=\
-       $(LINUX_DIR)/drivers/ata/pata_platform.$(LINUX_KMOD_SUFFIX) \
-       $(LINUX_DIR)/drivers/ata/pata_rb532_cf.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,41,pata_platform pata_rb532_cf,1)
-endef
-
-define KernelPackage/ata-rb532-cf/description
-  RB532 Compact Flash support.
-endef
-
-$(eval $(call KernelPackage,ata-rb532-cf))
 
 define KernelPackage/ata-nvidia-sata
 $(call AddDepends/ata,)
@@ -141,21 +81,6 @@ endef
 $(eval $(call KernelPackage,ata-nvidia-sata))
 
 
-define KernelPackage/ata-magicbox-cf
-$(call AddDepends/ata,@TARGET_ppc40x)
-  TITLE:=Magicbox v2/OpenRB Compact flash support
-  KCONFIG:=CONFIG_PATA_MAGICBOX_CF
-  FILES:=$(LINUX_DIR)/drivers/ata/pata_magicbox_cf.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,41,pata_magicbox_cf,1)
-endef
-
-define KernelPackage/ata-magicbox-cf/description
-  Support for Magicbox v2/OpenRB on-board CF slot.
-endef
-
-$(eval $(call KernelPackage,ata-magicbox-cf))
-
-
 define KernelPackage/ata-pdc202xx-old
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Older Promise PATA controller support
@@ -191,6 +116,36 @@ endef
 $(eval $(call KernelPackage,ata-piix))
 
 
+define KernelPackage/ata-sil
+$(call AddDepends/ata,)
+  TITLE:=Silicon Image SATA support
+  KCONFIG:=CONFIG_SATA_SIL
+  FILES:=$(LINUX_DIR)/drivers/ata/sata_sil.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,41,sata_sil,1)
+endef
+
+define KernelPackage/ata-sil/description
+ Support for Silicon Image Serial ATA controllers.
+endef
+
+$(eval $(call KernelPackage,ata-sil))
+
+
+define KernelPackage/ata-sil24
+$(call AddDepends/ata,)
+  TITLE:=Silicon Image 3124/3132 SATA support
+  KCONFIG:=CONFIG_SATA_SIL24
+  FILES:=$(LINUX_DIR)/drivers/ata/sata_sil24.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,41,sata_sil24,1)
+endef
+
+define KernelPackage/ata-sil24/description
+ Support for Silicon Image 3124/3132 Serial ATA controllers.
+endef
+
+$(eval $(call KernelPackage,ata-sil24))
+
+
 define KernelPackage/ata-via-sata
 $(call AddDepends/ata,)
   TITLE:=VIA SATA support
@@ -206,6 +161,46 @@ endef
 $(eval $(call KernelPackage,ata-via-sata))
 
 
+define KernelPackage/block2mtd
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=Block device MTD emulation
+  KCONFIG:=CONFIG_MTD_BLOCK2MTD
+  FILES:=$(LINUX_DIR)/drivers/mtd/devices/block2mtd.$(LINUX_KMOD_SUFFIX)
+endef
+
+$(eval $(call KernelPackage,block2mtd))
+
+
+define KernelPackage/dm
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=Device Mapper
+  # All the "=n" are unnecessary, they're only there
+  # to stop the config from asking the question.
+  # MIRROR is M because I've needed it for pvmove.
+  KCONFIG:= \
+       CONFIG_BLK_DEV_MD=n \
+       CONFIG_DM_DEBUG=n \
+       CONFIG_DM_CRYPT=n \
+       CONFIG_DM_UEVENT=n \
+       CONFIG_DM_DELAY=n \
+       CONFIG_DM_MULTIPATH=n \
+       CONFIG_DM_ZERO=n \
+       CONFIG_DM_SNAPSHOT=n \
+       CONFIG_DM_LOG_USERSPACE=n \
+       CONFIG_MD=y \
+       CONFIG_BLK_DEV_DM \
+       CONFIG_DM_MIRROR
+  FILES:=$(LINUX_DIR)/drivers/md/dm-*.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,30,dm-mod dm-log dm-region-hash dm-mirror)
+endef
+
+define KernelPackage/dm/description
+ Kernel module necessary for LVM2 support
+endef
+
+$(eval $(call KernelPackage,dm))
+
+
 define KernelPackage/ide-core
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=IDE (ATA/ATAPI) device support
@@ -348,33 +343,26 @@ endef
 $(eval $(call KernelPackage,ide-it821x))
 
 
-define KernelPackage/scsi-core
+define KernelPackage/libsas
   SUBMENU:=$(BLOCK_MENU)
-  TITLE:=SCSI device support
-  DEPENDS:=@!TARGET_x86
-  KCONFIG:= \
-       CONFIG_SCSI \
-       CONFIG_BLK_DEV_SD
+  TITLE:=SAS Domain Transport Attributes
+  DEPENDS:=@TARGET_x86
+  KCONFIG:=CONFIG_SCSI_SAS_LIBSAS \
+       CONFIG_SCSI_SAS_ATTRS \
+       CONFIG_SCSI_SAS_ATA=y \
+       CONFIG_SCSI_SAS_HOST_SMP=y \
+       CONFIG_SCSI_SAS_LIBSAS_DEBUG=y
   FILES:= \
-       $(if $(findstring y,$(CONFIG_SCSI)),,$(LINUX_DIR)/drivers/scsi/scsi_mod.$(LINUX_KMOD_SUFFIX)) \
-       $(LINUX_DIR)/drivers/scsi/sd_mod.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,20,scsi_mod,1) $(call AutoLoad,40,sd_mod,1)
+       $(LINUX_DIR)/drivers/scsi/scsi_transport_sas.$(LINUX_KMOD_SUFFIX) \
+       $(LINUX_DIR)/drivers/scsi/libsas/libsas.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,29,scsi_transport_sas libsas,1)
 endef
 
-$(eval $(call KernelPackage,scsi-core))
-
-
-define KernelPackage/scsi-generic
-  SUBMENU:=$(BLOCK_MENU)
-  TITLE:=Kernel support for SCSI generic
-  KCONFIG:= \
-       CONFIG_CHR_DEV_SG
-  FILES:= \
-       $(LINUX_DIR)/drivers/scsi/sg.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,65,sg)
+define KernelPackage/libsas/description
+  SAS Domain Transport Attributes support.
 endef
 
-$(eval $(call KernelPackage,scsi-generic))
+$(eval $(call KernelPackage,libsas,1))
 
 
 define KernelPackage/loop
@@ -394,6 +382,26 @@ endef
 $(eval $(call KernelPackage,loop))
 
 
+define KernelPackage/mvsas
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=Marvell 88SE6440 SAS/SATA driver
+  DEPENDS:=@TARGET_x86 +kmod-libsas
+  KCONFIG:=CONFIG_SCSI_MVSAS
+  ifneq ($(CONFIG_LINUX_2_6_25)$(CONFIG_LINUX_2_6_30),)
+       FILES:=$(LINUX_DIR)/drivers/scsi/mvsas.$(LINUX_KMOD_SUFFIX)
+  else
+       FILES:=$(LINUX_DIR)/drivers/scsi/mvsas/mvsas.$(LINUX_KMOD_SUFFIX)
+  endif
+  AUTOLOAD:=$(call AutoLoad,40,mvsas,1)
+endef
+
+define KernelPackage/mvsas/description
+  Kernel support for the Marvell SAS SCSI adapters
+endef
+
+$(eval $(call KernelPackage,mvsas))
+
+
 define KernelPackage/nbd
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Network block device support
@@ -409,131 +417,30 @@ endef
 $(eval $(call KernelPackage,nbd))
 
 
-define KernelPackage/dm
+define KernelPackage/scsi-core
   SUBMENU:=$(BLOCK_MENU)
-  TITLE:=Device Mapper
-  # All the "=n" are unnecessary, they're only there
-  # to stop the config from asking the question.
-  # MIRROR is M because I've needed it for pvmove.
+  TITLE:=SCSI device support
+  DEPENDS:=@!TARGET_x86
   KCONFIG:= \
-       CONFIG_BLK_DEV_MD=n \
-       CONFIG_DM_DEBUG=n \
-       CONFIG_DM_CRYPT=n \
-       CONFIG_DM_UEVENT=n \
-       CONFIG_DM_DELAY=n \
-       CONFIG_DM_MULTIPATH=n \
-       CONFIG_DM_ZERO=n \
-       CONFIG_DM_SNAPSHOT=n \
-       CONFIG_DM_LOG_USERSPACE=n \
-       CONFIG_MD=y \
-       CONFIG_BLK_DEV_DM \
-       CONFIG_DM_MIRROR
-  FILES:=$(LINUX_DIR)/drivers/md/dm-*.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,30,dm-mod dm-log dm-region-hash dm-mirror)
-endef
-
-define KernelPackage/dm/description
- Kernel module necessary for LVM2 support
-endef
-
-$(eval $(call KernelPackage,dm))
-
-
-define KernelPackage/pata-rb153-cf
-$(call AddDepends/ata,@TARGET_adm5120_router_le)
-  TITLE:=RouterBOARD 153 CF Slot support
-  KCONFIG:=CONFIG_PATA_RB153_CF
-  FILES:=$(LINUX_DIR)/drivers/ata/pata_rb153_cf.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,30,pata_rb153_cf,1)
-endef
-
-define KernelPackage/pata-rb153-cf/description
-  Kernel support for the RouterBoard 153 CF slot.
-endef
-
-$(eval $(call KernelPackage,pata-rb153-cf,1))
-
-
-define KernelPackage/aoe
-  SUBMENU:=$(BLOCK_MENU)
-  TITLE:=ATA over Ethernet support
-  KCONFIG:=CONFIG_ATA_OVER_ETH
-  FILES:=$(LINUX_DIR)/drivers/block/aoe/aoe.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,30,aoe)
-endef
-
-define KernelPackage/aoe/description
-  Kernel support for ATA over Ethernet
-endef
-
-$(eval $(call KernelPackage,aoe))
-
-define KernelPackage/ps3vram
-  SUBMENU:=$(BLOCK_MENU)
-  TITLE:=PS3 Video RAM Storage Driver
-  DEPENDS:=@TARGET_ps3||TARGET_ps3chk
-  KCONFIG:=CONFIG_PS3_VRAM
-  FILES:=$(LINUX_DIR)/drivers/block/ps3vram.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,01,ps3vram)
-endef
-
-define KernelPackage/ps3vram/description
-  Kernel support for PS3 Video RAM Storage
-endef
-
-$(eval $(call KernelPackage,ps3vram))
-
-define KernelPackage/axonram
-  SUBMENU:=$(BLOCK_MENU)
-  TITLE:=Axon DDR2 memory device driver
-  DEPENDS:=@TARGET_pxcab
-  KCONFIG:=CONFIG_AXON_RAM
-  FILES:=$(LINUX_DIR)/arch/powerpc/sysdev/axonram.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,01,axonram)
-endef
-
-define KernelPackage/axonram/description
-  Kernel support for Axon DDR2 memory device
-endef
-
-$(eval $(call KernelPackage,axonram))
-
-define KernelPackage/libsas
-  SUBMENU:=$(BLOCK_MENU)
-  TITLE:=SAS Domain Transport Attributes
-  DEPENDS:=@TARGET_x86
-  KCONFIG:=CONFIG_SCSI_SAS_LIBSAS \
-       CONFIG_SCSI_SAS_ATTRS \
-       CONFIG_SCSI_SAS_ATA=y \
-       CONFIG_SCSI_SAS_HOST_SMP=y \
-       CONFIG_SCSI_SAS_LIBSAS_DEBUG=y
+       CONFIG_SCSI \
+       CONFIG_BLK_DEV_SD
   FILES:= \
-       $(LINUX_DIR)/drivers/scsi/scsi_transport_sas.$(LINUX_KMOD_SUFFIX) \
-       $(LINUX_DIR)/drivers/scsi/libsas/libsas.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,29,scsi_transport_sas libsas,1)
+       $(if $(findstring y,$(CONFIG_SCSI)),,$(LINUX_DIR)/drivers/scsi/scsi_mod.$(LINUX_KMOD_SUFFIX)) \
+       $(LINUX_DIR)/drivers/scsi/sd_mod.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,20,scsi_mod,1) $(call AutoLoad,40,sd_mod,1)
 endef
 
-define KernelPackage/libsas/description
-  SAS Domain Transport Attributes support.
-endef
+$(eval $(call KernelPackage,scsi-core))
 
-$(eval $(call KernelPackage,libsas,1))
 
-define KernelPackage/mvsas
+define KernelPackage/scsi-generic
   SUBMENU:=$(BLOCK_MENU)
-  TITLE:=Marvell 88SE6440 SAS/SATA driver
-  DEPENDS:=@TARGET_x86 +kmod-libsas
-  KCONFIG:=CONFIG_SCSI_MVSAS
-  ifneq ($(CONFIG_LINUX_2_6_25)$(CONFIG_LINUX_2_6_30),)
-       FILES:=$(LINUX_DIR)/drivers/scsi/mvsas.$(LINUX_KMOD_SUFFIX)
-  else
-       FILES:=$(LINUX_DIR)/drivers/scsi/mvsas/mvsas.$(LINUX_KMOD_SUFFIX)
-  endif
-  AUTOLOAD:=$(call AutoLoad,40,mvsas,1)
-endef
-
-define KernelPackage/mvsas/description
-  Kernel support for the Marvell SAS SCSI adapters
+  TITLE:=Kernel support for SCSI generic
+  KCONFIG:= \
+       CONFIG_CHR_DEV_SG
+  FILES:= \
+       $(LINUX_DIR)/drivers/scsi/sg.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,65,sg)
 endef
 
-$(eval $(call KernelPackage,mvsas))
+$(eval $(call KernelPackage,scsi-generic))