[package] kernel: fix typo that prevents autoloading of the rdc321x_wdt driver
[openwrt.git] / package / kernel / modules / block.mk
index 3e22c458bb257e88305c241672c1c7f3c6f35891..cbdf2b3a0fd91e386bdf034a2cd2c6013e84ce6d 100644 (file)
@@ -10,7 +10,7 @@ BLOCK_MENU:=Block Devices
 define KernelPackage/ata-core
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Serial and Parallel ATA support
-  DEPENDS:=@PCI_SUPPORT @LINUX_2_6 +kmod-scsi-core
+  DEPENDS:=@PCI_SUPPORT @LINUX_2_6 +kmod-scsi-core @!TARGET_ubicom32
   KCONFIG:=CONFIG_ATA
   FILES:=$(LINUX_DIR)/drivers/ata/libata.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,21,libata)
@@ -66,6 +66,21 @@ endef
 
 $(eval $(call KernelPackage,ata-artop))
 
+define KernelPackage/ata-octeon-cf
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=Octeon Compact Flash support
+  DEPENDS:=kmod-ata-core @TARGET_octeon
+  KCONFIG:=CONFIG_PATA_OCTEON_CF
+  FILES:=$(LINUX_DIR)/drivers/ata/pata_octeon_cf.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,41,pata_octeon_cf)
+endef
+
+define KernelPackage/ata-octeon-cf/description
+  Octeon Compact Flash support.
+endef
+
+$(eval $(call KernelPackage,ata-octeon-cf))
+
 
 define KernelPackage/ata-ixp4xx-cf
   SUBMENU:=$(BLOCK_MENU)