[package] kernel/modules: Fix CH341 USB-to-serial description (#8097)
[openwrt.git] / package / kernel / modules / 001-depends.mk
index 826734ec9b60bc70b559efb9473e27e53080b11d..61d892198ec6d0a27c84f277f851c74446a142b6 100644 (file)
@@ -12,7 +12,26 @@ define SetDepends/crc16
 endef
 
 define AddDepends/crc16
-  DEPENDS+= +!TARGET_xburst:kmod-crc16
+  DEPENDS+= +!TARGET_xburst:kmod-crc16 $(1)
+endef
+
+
+define SetDepends/hid
+  DEPENDS:= @!TARGET_x86
+endef
+
+define AddDepends/hid
+  DEPENDS+= +!TARGET_x86:kmod-hid $(1)
+
+endef
+
+
+define SetDepends/input
+  DEPENDS:= @!TARGET_x86
+endef
+
+define AddDepends/input
+  DEPENDS+= +!TARGET_x86:kmod-input-core $(1)
 endef
 
 
@@ -21,6 +40,5 @@ define SetDepends/rfkill
 endef
 
 define AddDepends/rfkill
-  DEPENDS+= +(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86):kmod-rfkill
-
+  DEPENDS+= +(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86):kmod-rfkill $(1)
 endef