[package] kernel: package tulip family modules into kmod-tulip
[openwrt.git] / package / kernel / modules / 001-depends.mk
index 2446d3e4b916d585f7e1245f933c89b859bf44e5..5bba0870ee78305ccef7a6bd712331c19383b2e5 100644 (file)
@@ -8,9 +8,37 @@
 # XXX: xburst has CONFIG_CRC16=y because of CONFIG_UBIFS_FS=y
 
 define SetDepends/crc16
-  DEPENDS:= @!TARGET_xburst
+  DEPENDS:= @!(LINUX_2_4||TARGET_xburst)
 endef
 
 define AddDepends/crc16
-  DEPENDS+= +!TARGET_xburst:kmod-crc16
+  DEPENDS+= +!(LINUX_2_4||TARGET_xburst):kmod-crc16 $(1)
+endef
+
+
+define SetDepends/hid
+  DEPENDS:= @!TARGET_x86
+endef
+
+define AddDepends/hid
+  DEPENDS+= +!TARGET_x86:kmod-hid $(1)
+
+endef
+
+
+define SetDepends/input
+  DEPENDS:= @!TARGET_x86
+endef
+
+define AddDepends/input
+  DEPENDS+= +!TARGET_x86:kmod-input-core $(1)
+endef
+
+
+define SetDepends/rfkill
+  DEPENDS:= @(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86)
+endef
+
+define AddDepends/rfkill
+  DEPENDS+= +(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86):kmod-rfkill $(1)
 endef