package/kernel: fix dependency modules
[openwrt.git] / package / kernel / modules / 001-depends.mk
index 5cb34120813d85457ed2e8d245105efcc76738eb..5bba0870ee78305ccef7a6bd712331c19383b2e5 100644 (file)
@@ -8,11 +8,11 @@
 # XXX: xburst has CONFIG_CRC16=y because of CONFIG_UBIFS_FS=y
 
 define SetDepends/crc16
-  DEPENDS:= @!TARGET_xburst
+  DEPENDS:= @!(LINUX_2_4||TARGET_xburst)
 endef
 
 define AddDepends/crc16
-  DEPENDS+= +!TARGET_xburst:kmod-crc16
+  DEPENDS+= +!(LINUX_2_4||TARGET_xburst):kmod-crc16 $(1)
 endef
 
 
@@ -21,7 +21,7 @@ define SetDepends/hid
 endef
 
 define AddDepends/hid
-  DEPENDS+= +!TARGET_x86:kmod-hid
+  DEPENDS+= +!TARGET_x86:kmod-hid $(1)
 
 endef
 
@@ -31,7 +31,7 @@ define SetDepends/input
 endef
 
 define AddDepends/input
-  DEPENDS+= +!TARGET_x86:kmod-input-core
+  DEPENDS+= +!TARGET_x86:kmod-input-core $(1)
 endef
 
 
@@ -40,6 +40,5 @@ define SetDepends/rfkill
 endef
 
 define AddDepends/rfkill
-  DEPENDS+= +(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86):kmod-rfkill
-
+  DEPENDS+= +(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86):kmod-rfkill $(1)
 endef