netifd: update, prefix proto handler callbacks with 'proto_'
[openwrt.git] / package / kernel / modules / 001-depends.mk
index 2446d3e4b916d585f7e1245f933c89b859bf44e5..238799e2e54c6d4dcd469598e203d8f36e187986 100644 (file)
@@ -12,5 +12,33 @@ define SetDepends/crc16
 endef
 
 define AddDepends/crc16
-  DEPENDS+= +!TARGET_xburst:kmod-crc16
+  DEPENDS+= +!TARGET_xburst:kmod-crc16 $(1)
+endef
+
+
+define SetDepends/hid
+  DEPENDS:= @!TARGET_x86
+endef
+
+define AddDepends/hid
+  DEPENDS+= +!TARGET_x86:kmod-hid $(1)
+
+endef
+
+
+define SetDepends/input
+  DEPENDS:= @!(TARGET_x86_generic||TARGET_x86_kvm_guest)
+endef
+
+define AddDepends/input
+  DEPENDS+= +!(TARGET_x86_generic||TARGET_x86_kvm_guest):kmod-input-core $(1)
+endef
+
+
+define SetDepends/rfkill
+  DEPENDS:= @(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_gemini)
+endef
+
+define AddDepends/rfkill
+  DEPENDS+= +(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86):kmod-rfkill $(1)
 endef