[scripts] ext-toolchain.sh: properly handle toolchains without sysroot support
[openwrt.git] / package / kernel / Makefile
index d3823547aa3acac5eefd9b43641b047ca1d9cd77..e094c601ef4f74cfedc40d1866082d7e7015cb86 100644 (file)
@@ -35,7 +35,7 @@ define Package/kernel
   CATEGORY:=Kernel
   DEFAULT:=y
   TITLE:=Virtual kernel package
-  VERSION:=$(LINUX_VERSION)-$(LINUX_RELEASE)
+  VERSION:=$(LINUX_VERSION)-$(LINUX_RELEASE)-$(LINUX_VERMAGIC)
   URL:=http://www.kernel.org/
 endef
 
@@ -45,5 +45,5 @@ endef
 
 $(eval $(if $(DUMP),,$(call BuildPackage,kernel)))
 
-include ./modules/*.mk
+include $(sort $(wildcard ./modules/*.mk))
 -include $(TOPDIR)/target/linux/*/modules.mk