add basic support for the Magicbox boards
[openwrt.git] / package / iptables / Makefile
index 34e68174378379a750f63e151d99924cf26245ce..8d77fb43f475ed4274f9f2011b8afd6510afe0c4 100644 (file)
@@ -1,7 +1,13 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # $Id$
 
 include $(TOPDIR)/rules.mk
-include $(TOPDIR)/package/kernel.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=iptables
 PKG_VERSION:=1.3.5
@@ -20,10 +26,10 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 PKG_MENU:=IPv4 / IPv6 firewall administration
 
-include $(TOPDIR)/package/rules.mk
+include $(INCLUDE_DIR)/package.mk
 ifeq ($(DUMP),)
-include $(LINUX_DIR)/.config
-include $(TOPDIR)/target/linux/netfilter.mk
+-include $(LINUX_DIR)/.config
+include $(INCLUDE_DIR)/netfilter.mk
 endif
 
 define Package/iptables
@@ -35,46 +41,48 @@ TITLE:=IPv4 firewall administration tool
 URL:=http://netfilter.org/
 endef
 
+define Package/iptables/conffiles
+/etc/config/firewall
+/etc/firewall.user
+endef
+
 define Package/iptables-mod-conntrack
 SECTION:=net
 CATEGORY:=Base system
-DEPENDS:=iptables
+DEPENDS:=iptables +kmod-ipt-conntrack
 TITLE:=connection tracking modules
 DESCRIPTION:=iptables extensions for connection tracking \\\
 Includes: \\\
        * libipt_conntrack \\\
        * libipt_helper \\\
        * libipt_connmark/CONNMARK
-
 endef
 
 define Package/iptables-mod-filter
 SECTION:=net
 CATEGORY:=Base system
-DEPENDS:=iptables
+DEPENDS:=iptables +kmod-ipt-filter
 TITLE:=filter modules
 DESCRIPTION:=iptables extensions for packet content inspection\\\
 Includes: \\\
        * libipt_ipp2p \\\
        * libipt_layer7 
-                                               
 endef
 
 define Package/iptables-mod-imq
 SECTION:=net
 CATEGORY:=Base system
 DEPENDS:=iptables
-TITLE:=IMQ support
+TITLE:=IMQ support +kmod-imq
 DESCRIPTION:=iptables extension for IMQ support\\\
 Includes: \\\
        * libipt_IMQ
-                                               
 endef
 
 define Package/iptables-mod-ipopt
 SECTION:=net
 CATEGORY:=Base system
-DEPENDS:=iptables
+DEPENDS:=iptables +kmod-ipt-ipopt
 TITLE:=IP/Packet option modules
 DESCRIPTION:=iptables extensions for matching/changing IP packet options\\\
 Includes: \\\
@@ -86,25 +94,23 @@ Includes: \\\
        * libipt_tcpmms \\\
        * libipt_ttl/TTL \\\
        * libipt_unclean 
-
 endef
 
 define Package/iptables-mod-ipsec
 SECTION:=net
 CATEGORY:=Base system
-DEPENDS:=iptables
+DEPENDS:=iptables +kmod-ipt-ipsec
 TITLE:=IPSec extensions
 DESCRIPTION:=iptables extensions for matching ipsec traffic\\\
 Includes: \\\
        * libipt_ah \\\
        * libipt_esp
-
 endef
 
 define Package/iptables-mod-nat
 SECTION:=net
 CATEGORY:=Base system
-DEPENDS:=iptables
+DEPENDS:=iptables +kmod-ipt-nat
 TITLE:=extra NAT targets
 DESCRIPTION:=iptables extensions for different NAT targets\\\
 Includes: \\\
@@ -114,7 +120,7 @@ endef
 define Package/iptables-mod-ulog
 SECTION:=net
 CATEGORY:=Base system
-DEPENDS:=iptables
+DEPENDS:=iptables +kmod-ipt-ulog
 TITLE:=user-space packet logging
 DESCRIPTION:=iptables extensions for user-space packet logging\\\
 Includes: \\\
@@ -124,7 +130,7 @@ endef
 define Package/iptables-mod-extra
 SECTION:=net
 CATEGORY:=Base system
-DEPENDS:=iptables
+DEPENDS:=iptables +kmod-ipt-extra
 TITLE:=other extra iptables extensions
 DESCRIPTION:=other extra iptables extensions\\\
 Includes: \\\
@@ -133,7 +139,6 @@ Includes: \\\
        * libipt_physdev \\\
        * libipt_pkttype \\\
        * libipt_recent
-
 endef
 
 define Package/iptables-utils
@@ -158,8 +163,8 @@ define Build/Compile
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               CC=$(TARGET_CC) COPT_FLAGS="$(TARGET_CFLAGS)" \
-               KERNEL_DIR=$(LINUX_DIR) PREFIX=/usr \
+               COPT_FLAGS="$(TARGET_CFLAGS)" \
+               KERNEL_DIR="$(LINUX_DIR)" PREFIX=/usr \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install install-devel
 endef
@@ -168,8 +173,8 @@ endef
 define Build/InstallDev
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               CC=$(TARGET_CC) COPT_FLAGS="$(TARGET_CFLAGS)" \
-               KERNEL_DIR=$(LINUX_DIR) PREFIX=/usr \
+               COPT_FLAGS="$(TARGET_CFLAGS)" \
+               KERNEL_DIR="$(LINUX_DIR)" PREFIX=/usr \
                DESTDIR="$(STAGING_DIR)" \
                install install-devel
 endef
@@ -194,13 +199,11 @@ define Package/iptables/install
        (cd $(PKG_INSTALL_DIR)/usr/lib/iptables ; \
                $(CP) $(patsubst %,lib%.so,$(IPT_BUILTIN:xt_%=ipt_%)) $(1)/usr/lib/iptables/ \
        )
-       $(RSTRIP) $(1)
 endef
 
 define Package/iptables-utils/install
        install -d -m0755 $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/iptables-{save,restore} $(1)/usr/sbin/
-       $(RSTRIP) $(1)
 endef
 
 define Package/ip6tables/install
@@ -210,7 +213,6 @@ define Package/ip6tables/install
        (cd $(PKG_INSTALL_DIR)/usr/lib/iptables ; \
                $(CP) libip6t_*.so $(1)/usr/lib/iptables/ \
        )
-       $(RSTRIP) $(1)
 endef
 
 define BuildPlugin
@@ -220,7 +222,6 @@ define Package/$(1)/install
                $(CP) $(PKG_INSTALL_DIR)/usr/lib/iptables/lib$$$$$$$${m}.so $$(1)/usr/lib/iptables/ ; \
        done
        $(3)
-       $(RSTRIP) $$(1)
 endef
 
 $$(eval $$(call BuildPackage,$(1)))