hostapd: move the madwifi segfault fix to the right place
[openwrt.git] / package / iptables / Makefile
index 7c849cb3a63cd6cb12ab5dd84a7314c7b8b7a6e8..2647f683974a6ece247036273a403a106e7c6bdd 100644 (file)
@@ -21,12 +21,13 @@ PKG_SOURCE_URL:=http://www.netfilter.org/projects/iptables/files \
 
 PKG_FIXUP:=libtool
 PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 ifeq ($(DUMP),)
   -include $(LINUX_DIR)/.config
   include $(INCLUDE_DIR)/netfilter.mk
-  STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell grep 'NETFILTER' $(LINUX_DIR)/.config | md5s)
+  STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell $(SH_FUNC) grep 'NETFILTER' $(LINUX_DIR)/.config | md5s)
 endif
 
 
@@ -304,9 +305,9 @@ MAKE_FLAGS := \
        KERNEL_DIR="$(LINUX_DIR)" PREFIX=/usr \
        KBUILD_OUTPUT="$(LINUX_DIR)" \
 
-define Build/Prepare
-$(call Build/Prepare/Default)
+define Build/Configure
        (cd $(PKG_BUILD_DIR); ./autogen.sh)
+$(call Build/Configure/Default)
 endef
 
 define Build/InstallDev
@@ -353,6 +354,10 @@ endef
 define Package/ip6tables/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ip6tables $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/lib/iptables
+       (cd $(PKG_INSTALL_DIR)/usr/lib/iptables ; \
+               $(CP) libip6t_*.so $(1)/usr/lib/iptables/ \
+       )
 endef
 
 define Package/ip6tables-utils/install