Add raw and NOTRACK targets (#1583)
[openwrt.git] / package / iptables / Makefile
index c7f73f1ccf08d36347dff998d580b2a2b02ad49f..1bd13a507de4530e27e1954a069cc233e7669005 100644 (file)
@@ -19,12 +19,12 @@ PKG_SOURCE_URL:=http://www.netfilter.org/projects/iptables/files \
        ftp://ftp.de.netfilter.org/pub/netfilter/iptables/ \
        ftp://ftp.no.netfilter.org/pub/netfilter/iptables/
 PKG_MD5SUM:=00fb916fa8040ca992a5ace56d905ea5
-PKG_CAT:=bzcat
 
 include $(INCLUDE_DIR)/package.mk
 ifeq ($(DUMP),)
   -include $(LINUX_DIR)/.config
   include $(INCLUDE_DIR)/netfilter.mk
+  STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell grep 'NETFILTER' $(LINUX_DIR)/.config | md5s)
 endif
 
 define Package/iptables/Default
@@ -145,7 +145,8 @@ define Package/iptables-mod-extra
        - libipt_owner \\\
        - libipt_physdev \\\
        - libipt_pkttype \\\
-       - libipt_recent
+       - libipt_recent \\\
+       - libipt_NOTRACK
 endef
 
 define Package/iptables-utils
@@ -160,9 +161,8 @@ define Package/ip6tables
   TITLE:=IPv6 firewall administration tool
 endef
 
-$(PKG_BUILD_DIR)/.configured: $(LINUX_DIR)/.config
-
 define Build/Configure
+       rm -f $(PKG_BUILD_DIR)/.configured*
        $(MAKE) -C $(PKG_BUILD_DIR) \
                clean
 endef
@@ -173,6 +173,7 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
                COPT_FLAGS="$(TARGET_CFLAGS)" \
+               LDFLAGS="-rdynamic -static-libgcc" \
                KERNEL_DIR="$(LINUX_DIR)" PREFIX=/usr \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install