add basic support for the Magicbox boards
[openwrt.git] / package / iproute2 / Makefile
index bbbcc758c3ac58024ebded55b178ee7f0d664390..4ad88d8f348b1732c0a0ce20a5f2aac43b9c1ff5 100644 (file)
@@ -1,3 +1,9 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # $Id$
 
 include $(TOPDIR)/rules.mk
@@ -17,7 +23,6 @@ include $(INCLUDE_DIR)/package.mk
 define Package/ip
 SECTION:=base
 CATEGORY:=Network
-DEPENDS:=iproute2
 TITLE:=A routing control utility
 endef
 
@@ -39,7 +44,7 @@ define Build/Configure
 endef
 
 define Build/Compile
-       $(MAKE) -j1 -C $(PKG_BUILD_DIR)/netem HOSTCC=$(HOSTCC) CFLAGS="-D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall -I ../include -DRESOLVE_HOSTNAMES"
+       $(MAKE) -j1 -C $(PKG_BUILD_DIR)/netem HOSTCC="$(HOSTCC)" CFLAGS="-D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall -I ../include -DRESOLVE_HOSTNAMES"
        $(MAKE) -j1 -C $(PKG_BUILD_DIR) $(TARGET_CONFIGURE_OPTS) KERNEL_INCLUDE=$(LINUX_DIR)/include all tc/tc ip/ip
 endef