make morse LED trigger available as a package, and fix it to compile with 2.6.23
[openwrt.git] / package / gdbserver / Makefile
index d4d149102df76be8b75c9b73dcca586b5b9c3af8..4fac7af2df6b0a5351aadbdafc343367e39f5496 100644 (file)
@@ -11,20 +11,20 @@ PKG_NAME:=gdbserver
 PKG_VERSION:=6.3
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-GDB_DIR:=$(TOOLCHAIN_BUILD_DIR)/gdb-$(PKG_VERSION)
+GDB_DIR:=$(BUILD_DIR_TOOLCHAIN)/gdb-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/gdbserver
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=@GDB@
+  DEPENDS:=@GDB
   TITLE:=Remote Server for the GNU Debugger
-  DESCRIPTION:=GDBSERVER is a program that allows you to run GDB on a different machine\\\
-than the one which is running the program being debugged.
+endef
+
+define Package/gdbserver/description
+ GDBSERVER is a program that allows you to run GDB on a different machine 
+ than the one which is running the program being debugged.
 endef
 
 define Build/Configure