[package] libuuid needs to be compiled with fPIC/pic.
[openwrt.git] / package / e2fsprogs / Makefile
index 90866a8ab9a5fabba9e730e61ac855b594b1bf48..c05105aab7658781a4f5c807edaed907d2129267 100644 (file)
@@ -8,13 +8,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=e2fsprogs
-ifneq ($(findstring "0.9.29",$(CONFIG_UCLIBC_VERSION)),"0.9.29")
-PKG_VERSION:=1.41.9
-PKG_MD5SUM:=52f60a9e19a02f142f5546f1b5681927
-else
 PKG_VERSION:=1.40.11
 PKG_MD5SUM:=004cea70d724fdc7f1a952dffe4c9db8
-endif
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -112,6 +107,8 @@ $(call Package/e2fsprogs)
   DEPENDS:=libuuid libblkid
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \