[package] libuuid needs to be compiled with fPIC/pic.
[openwrt.git] / package / e2fsprogs / Makefile
index 3a66b3e14c91aa5d508f3d1be763452928dba715..c05105aab7658781a4f5c807edaed907d2129267 100644 (file)
@@ -8,25 +8,26 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=e2fsprogs
-PKG_VERSION:=1.41.3
-PKG_RELEASE:=3
+PKG_VERSION:=1.40.11
+PKG_MD5SUM:=004cea70d724fdc7f1a952dffe4c9db8
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/e2fsprogs
-PKG_MD5SUM:=b21d26fc46c584021dc9c444933ee1c2
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/e2fsprogs/Default
   URL:=http://e2fsprogs.sourceforge.net/
+  SUBMENU:=Filesystem
 endef
 
 define Package/e2fsprogs
 $(call Package/e2fsprogs/Default)
   SECTION:=utils
   CATEGORY:=Utilities
-  TITLE:=Ext2/3 filesystem utilities
-  DEPENDS:=+libblkid +libuuid +libext2fs
+  TITLE:=Ext2/3/4 filesystem utilities
+  DEPENDS:=+libblkid +libuuid +libext2fs +libpthread
 endef
 
 define Package/e2fsprogs/description
@@ -75,11 +76,11 @@ define Package/libext2fs
 $(call Package/e2fsprogs/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  TITLE:=ext2/ext3 filesystem library
+  TITLE:=ext2/3/4 filesystem library
 endef
 
 define Package/libext2fs/description
-libext2fs is a library which can access ext2 and ext3 filesystems.
+libext2fs is a library which can access ext2, ext3 and ext4 filesystems.
 endef
 
 define Package/tune2fs
@@ -103,9 +104,11 @@ endef
 define Package/blkid
 $(call Package/e2fsprogs)
   TITLE:=Command-line utility to locate/print block device attributes
-  DEPENDS:=e2fsprogs
+  DEPENDS:=libuuid libblkid
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
@@ -149,6 +152,7 @@ define Package/e2fsprogs/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/mke2fs $(1)/usr/sbin/
        ln -sf mke2fs $(1)/usr/sbin/mkfs.ext2
        ln -sf mke2fs $(1)/usr/sbin/mkfs.ext3
+       ln -sf mke2fs $(1)/usr/sbin/mkfs.ext4
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(foreach lib,com_err e2p,$(PKG_INSTALL_DIR)/usr/lib/lib$(lib).so.*) $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/etc/init.d