mark the llvm toolchain as broken
[openwrt.git] / package / e2fsprogs / Makefile
index 4b2a30b687f93b1030ea60a7f0e088d42530b731..49f0eca4fc20acebec16d1f37b8db8e6276e1fc2 100644 (file)
@@ -8,25 +8,26 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=e2fsprogs
-PKG_VERSION:=1.41.3
-PKG_RELEASE:=4
+PKG_VERSION:=1.41.9
+PKG_MD5SUM:=52f60a9e19a02f142f5546f1b5681927
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/e2fsprogs
-PKG_MD5SUM:=b21d26fc46c584021dc9c444933ee1c2
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/e2fsprogs/Default
   URL:=http://e2fsprogs.sourceforge.net/
+  SUBMENU:=Filesystem
 endef
 
 define Package/e2fsprogs
 $(call Package/e2fsprogs/Default)
   SECTION:=utils
   CATEGORY:=Utilities
-  TITLE:=Ext2/3 filesystem utilities
-  DEPENDS:=+libblkid +libuuid +libext2fs
+  TITLE:=Ext2/3/4 filesystem utilities
+  DEPENDS:=+libblkid +libuuid +libext2fs +libpthread
 endef
 
 define Package/e2fsprogs/description
@@ -75,11 +76,11 @@ define Package/libext2fs
 $(call Package/e2fsprogs/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  TITLE:=ext2/ext3 filesystem library
+  TITLE:=ext2/3/4 filesystem library
 endef
 
 define Package/libext2fs/description
-libext2fs is a library which can access ext2 and ext3 filesystems.
+libext2fs is a library which can access ext2, ext3 and ext4 filesystems.
 endef
 
 define Package/tune2fs
@@ -149,6 +150,7 @@ define Package/e2fsprogs/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/mke2fs $(1)/usr/sbin/
        ln -sf mke2fs $(1)/usr/sbin/mkfs.ext2
        ln -sf mke2fs $(1)/usr/sbin/mkfs.ext3
+       ln -sf mke2fs $(1)/usr/sbin/mkfs.ext4
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(foreach lib,com_err e2p,$(PKG_INSTALL_DIR)/usr/lib/lib$(lib).so.*) $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/etc/init.d