[package] add dropkey ssh keys and config files to the conffiles section (#2014)
[openwrt.git] / package / dropbear / Makefile
index bbea72fee4420909715edfe86b2593844e02127a..5943fc62c066b9ef2a8c22838cb4e91dcfd01ddd 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dropbear
 PKG_VERSION:=0.51
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= \
@@ -35,6 +35,12 @@ define Package/dropbear/description
  A small SSH2 server/client designed for small memory environments.
 endef
 
+define Package/dropbear/conffiles
+/etc/dropbear/dropbear_rsa_host_key
+/etc/dropbear/dropbear_dss_host_key 
+/etc/config/dropbear 
+endef
+
 define Package/dropbearconvert
   $(call Package/dropbear/Default)
   SECTION:=utils
@@ -47,7 +53,7 @@ CONFIGURE_ARGS += \
        --disable-pam \
        --enable-openpty \
        --enable-syslog \
-       --disable-shadow \
+       $(if $(CONFIG_SHADOW_PASSWORDS),,--disable-shadow) \
        --disable-lastlog \
        --disable-utmp \
        --disable-utmpx \
@@ -88,9 +94,10 @@ define Package/dropbear/install
        $(INSTALL_DATA) ./files/dropbear.config $(1)/etc/config/dropbear
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/dropbear.init $(1)/etc/init.d/dropbear
-       $(INSTALL_DIR) $(1)/usr/lib/ipkg/info
-       echo /etc/dropbear/dropbear_rsa_host_key > $(1)/usr/lib/ipkg/info/dropbear.conffiles
-       echo /etc/dropbear/dropbear_dss_host_key >> $(1)/usr/lib/ipkg/info/dropbear.conffiles
+       $(INSTALL_DIR) $(1)/usr/lib/opkg/info
+       $(INSTALL_DIR) $(1)/etc/dropbear
+       touch $(1)/etc/dropbear/dropbear_rsa_host_key
+       touch $(1)/etc/dropbear/dropbear_dss_host_key
 endef
 
 define Package/dropbearconvert/install