Fit new sourceforge.net download page layout, thanks to Fabian Deutsch for reporting...
[openwrt.git] / package / dosfstools / Makefile
index 2ac745a1dd6953df88272cca9745d75aec421664..91b455e9db0e126cbcd843993fef0420ce921524 100644 (file)
@@ -14,8 +14,6 @@ PKG_CAT:=zcat
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
-BR2_PACKAGE_DOSFSTOOLS=m
-
 include $(TOPDIR)/package/rules.mk
 
 $(eval $(call PKG_template,DOSFSTOOLS,dosfstools,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
@@ -35,10 +33,10 @@ $(PKG_BUILD_DIR)/.built:
 
 $(IPKG_DOSFSTOOLS):
        install -d -m0755 $(IDIR_DOSFSTOOLS)/sbin
-       cp -fpR $(PKG_INSTALL_DIR)/sbin/dosfsck $(IDIR_DOSFSTOOLS)/sbin/
-       cp -fpR $(PKG_INSTALL_DIR)/sbin/fsck.{msdos,vfat} $(IDIR_DOSFSTOOLS)/sbin/
-       cp -fpR $(PKG_INSTALL_DIR)/sbin/mkdosfs $(IDIR_DOSFSTOOLS)/sbin/
-       cp -fpR $(PKG_INSTALL_DIR)/sbin/mkfs.{msdos,vfat} $(IDIR_DOSFSTOOLS)/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/sbin/dosfsck $(IDIR_DOSFSTOOLS)/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/sbin/fsck.{msdos,vfat} $(IDIR_DOSFSTOOLS)/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/sbin/mkdosfs $(IDIR_DOSFSTOOLS)/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/sbin/mkfs.{msdos,vfat} $(IDIR_DOSFSTOOLS)/sbin/
        $(RSTRIP) $(IDIR_DOSFSTOOLS)
        $(IPKG_BUILD) $(IDIR_DOSFSTOOLS) $(PACKAGE_DIR)