move diag from target/linux/package/ to package/.
[openwrt.git] / package / dnsmasq / Makefile
index 64ae0f49f0f4c1a91fe8185901f6d368a8f04053..d3ce64736b7aa371eb16861cb7450cee4d3fd12c 100644 (file)
@@ -3,34 +3,33 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
-PKG_VERSION:=2.25
+PKG_VERSION:=2.27
 PKG_RELEASE:=1
-PKG_MD5SUM:=a5a387aed551acf91990567a5e8e4fa4
 
-PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
+PKG_MD5SUM:=489198ec87101087043adc98bbe062dc
 PKG_CAT:=zcat
 
 include $(TOPDIR)/package/rules.mk
 
-$(eval $(call PKG_template,DNSMASQ,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
-       touch $@
-
-$(PKG_BUILD_DIR)/.built:
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS)" \
-               BINDIR=/usr/sbin MANDIR=/usr/man
-       touch $@
-
-$(IPKG_DNSMASQ):
-       install -d -m0755 $(IDIR_DNSMASQ)/usr/sbin
-       cp $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(IDIR_DNSMASQ)/usr/sbin/
-       $(STRIP) $(IDIR_DNSMASQ)/usr/sbin/*
-       install -d -m0755 $(IDIR_DNSMASQ)/etc/init.d/
-       install -m0644 ./files/dnsmasq.conf $(IDIR_DNSMASQ)/etc/dnsmasq.conf
-       install -m0755 ./files/S50dnsmasq $(IDIR_DNSMASQ)/etc/init.d/S50dnsmasq
-       $(IPKG_BUILD) $(IDIR_DNSMASQ) $(PACKAGE_DIR)
-
+define Package/dnsmasq
+SECTION:=base
+CATEGORY:=Network
+DEFAULT:=y
+TITLE:=A lightweight DNS and DHCP server
+DESCRIPTION:=A lightweight DNS and DHCP server.  It is intended to provide \\\
+coupled DNS and DHCP service to a LAN.
+URL:=http://www.thekelleys.org.uk/dnsmasq/
+endef
+
+define Package/dnsmasq/install
+       install -m0755 -d $(1)/usr/sbin
+       install -m0755 -d $(1)/etc/init.d/
+       install -m0755 $(PKG_BUILD_DIR)/src/dnsmasq $(1)/usr/sbin/
+       install -m0644 ./files/dnsmasq.conf $(1)/etc/dnsmasq.conf
+       install -m0755 ./files/dnsmasq.init $(1)/etc/init.d/S50dnsmasq
+endef
+
+$(eval $(call BuildPackage,dnsmasq))