add the 'goldfish' target, useful for experimenting with virtual phone hardware ...
[openwrt.git] / package / dnsmasq / Makefile
index 6051db9d71b3be26001fffc76dee3010c1483c6a..3444efefff043c7a8d888e98cfeda1d682c791c4 100644 (file)
@@ -1,20 +1,19 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
-PKG_VERSION:=2.46
+PKG_VERSION:=2.49
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
-PKG_MD5SUM:=79ec740d1a10ee75f13efa4ff36d0250
+PKG_MD5SUM:=7ccc861d8a733474f9c0a0a127006ee9
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -29,6 +28,10 @@ define Package/dnsmasq/description
  It is intended to provide coupled DNS and DHCP service to a LAN.
 endef
 
+define Package/dnsmasq/conffiles
+/etc/config/dhcp
+endef
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \