libubox: update to fix a compile error
[openwrt.git] / package / comgt / Makefile
index c3cf8ed1b53a88830e0f6c44d1ce9f5169674411..61c123a737fdb10532ddd24d16238df2742fc857 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=comgt
 PKG_VERSION:=0.32
-PKG_RELEASE:=7
+PKG_RELEASE:=9
 
 PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/comgt
@@ -37,12 +37,14 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
-               gcom
+               LDFLAGS="" \
+               comgt
 endef
-       
+
 define Package/comgt/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/gcom $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/comgt $(1)/usr/bin/
+       ln -s comgt $(1)/usr/bin/gcom
        $(INSTALL_DIR) $(1)/etc/ppp
        $(INSTALL_BIN) ./files/3g.connect $(1)/etc/ppp/3g.connect
        $(INSTALL_DIR) $(1)/etc/chatscripts
@@ -54,8 +56,8 @@ define Package/comgt/install
        $(INSTALL_DATA) ./files/3g.button $(1)/etc/hotplug.d/button/05-3g
        $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
        $(INSTALL_DATA) ./files/3g.iface $(1)/etc/hotplug.d/iface/05-3g
-       $(INSTALL_DIR) $(1)/etc/hotplug.d/usb
-       $(INSTALL_DATA) ./files/3g.usb $(1)/etc/hotplug.d/usb/30-3g
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/tty
+       $(INSTALL_DATA) ./files/3g.usb $(1)/etc/hotplug.d/tty/30-3g
        $(INSTALL_DIR) $(1)/etc/gcom
        $(INSTALL_DATA) ./files/setpin.gcom $(1)/etc/gcom/setpin.gcom
        $(INSTALL_DATA) ./files/setmode.gcom $(1)/etc/gcom/setmode.gcom