libubox: update to fix a compile error
[openwrt.git] / package / comgt / Makefile
index 49cc08bbf123bc5e9bef5fb09dea46ea97ac1fed..61c123a737fdb10532ddd24d16238df2742fc857 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=comgt
 PKG_VERSION:=0.32
-PKG_RELEASE:=8
+PKG_RELEASE:=9
 
 PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/comgt
@@ -37,12 +37,14 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
-               gcom
+               LDFLAGS="" \
+               comgt
 endef
-       
+
 define Package/comgt/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/gcom $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/comgt $(1)/usr/bin/
+       ln -s comgt $(1)/usr/bin/gcom
        $(INSTALL_DIR) $(1)/etc/ppp
        $(INSTALL_BIN) ./files/3g.connect $(1)/etc/ppp/3g.connect
        $(INSTALL_DIR) $(1)/etc/chatscripts