awx: fix a typo
[openwrt.git] / package / busybox / patches / 913-libbb_hash.patch
index a7c2291caa28f03e1396a37bdbd2f37293d4c128..a9cb23988e479320194005223aa215ef427ffa33 100644 (file)
@@ -1,14 +1,7 @@
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# expose (again) an hash_fd function (used in 911-ipkg.patch)
-#
-diff -ruN busybox-1.2.0-orig/coreutils/md5_sha1_sum.c busybox-1.2.0-libbb_hash/coreutils/md5_sha1_sum.c
---- busybox-1.2.0-orig/coreutils/md5_sha1_sum.c        2006-07-01 00:42:07.000000000 +0200
-+++ busybox-1.2.0-libbb_hash/coreutils/md5_sha1_sum.c  2006-07-22 17:08:02.000000000 +0200
-@@ -16,79 +16,10 @@
+diff -ur busybox.old/coreutils/md5_sha1_sum.c busybox.dev/coreutils/md5_sha1_sum.c
+--- busybox.old/coreutils/md5_sha1_sum.c       2007-01-19 22:23:05.000000000 +0100
++++ busybox.dev/coreutils/md5_sha1_sum.c       2007-01-22 13:24:51.000000000 +0100
+@@ -8,76 +8,10 @@
  
  #include "busybox.h"
  
@@ -20,17 +13,12 @@ diff -ruN busybox-1.2.0-orig/coreutils/md5_sha1_sum.c busybox-1.2.0-libbb_hash/c
  
 -/* This might be useful elsewhere */
 -static unsigned char *hash_bin_to_hex(unsigned char *hash_value,
--                                                                        unsigned char hash_length)
+-                              unsigned hash_length)
 -{
--      int x, len, max;
--      unsigned char *hex_value;
--
--      max = (hash_length * 2) + 2;
--      hex_value = xmalloc(max);
--      for (x = len = 0; x < hash_length; x++) {
--              len += snprintf((char*)(hex_value + len), max - len, "%02x", hash_value[x]);
--      }
--      return (hex_value);
+-      /* xzalloc zero-terminates */
+-      char *hex_value = xzalloc((hash_length * 2) + 1);
+-      bin2hex(hex_value, (char*)hash_value, hash_length);
+-      return hex_value;
 -}
 -
 -static uint8_t *hash_file(const char *filename, hash_algo_t hash_algo)
@@ -45,11 +33,13 @@ diff -ruN busybox-1.2.0-orig/coreutils/md5_sha1_sum.c busybox-1.2.0-libbb_hash/c
 -      void (*update)(const void*, size_t, void*);
 -      void (*final)(void*, void*);
 -
--      if (strcmp(filename, "-") == 0) {
--              src_fd = STDIN_FILENO;
--      } else if(0 > (src_fd = open(filename, O_RDONLY))) {
--              bb_perror_msg("%s", filename);
--              return NULL;
+-      src_fd = STDIN_FILENO;
+-      if (NOT_LONE_DASH(filename)) {
+-              src_fd = open(filename, O_RDONLY);
+-              if (src_fd < 0) {
+-                      bb_perror_msg("%s", filename);
+-                      return NULL;
+-              }
 -      }
 -
 -      /* figure specific hash algorithims */
@@ -67,7 +57,7 @@ diff -ruN busybox-1.2.0-orig/coreutils/md5_sha1_sum.c busybox-1.2.0-libbb_hash/c
 -              bb_error_msg_and_die("algorithm not supported");
 -      }
 -
--      while (0 < (count = read(src_fd, in_buf, 4096))) {
+-      while (0 < (count = safe_read(src_fd, in_buf, 4096))) {
 -              update(in_buf, count, &context);
 -      }
 -
@@ -85,36 +75,43 @@ diff -ruN busybox-1.2.0-orig/coreutils/md5_sha1_sum.c busybox-1.2.0-libbb_hash/c
 -      return hash_value;
 -}
 -
- /* This could become a common function for md5 as well, by using md5_stream */
- static int hash_files(int argc, char **argv, hash_algo_t hash_algo)
+ int md5_sha1_sum_main(int argc, char **argv)
  {
-diff -ruN busybox-1.2.0-orig/include/libbb.h busybox-1.2.0-libbb_hash/include/libbb.h
---- busybox-1.2.0-orig/include/libbb.h 2006-07-01 00:42:10.000000000 +0200
-+++ busybox-1.2.0-libbb_hash/include/libbb.h   2006-07-22 17:01:06.000000000 +0200
-@@ -518,6 +518,8 @@
- extern int get_terminal_width_height(int fd, int *width, int *height);
- extern unsigned long get_ug_id(const char *s, long (*__bb_getxxnam)(const char *));
+       int return_value = EXIT_SUCCESS;
+diff -ur busybox.old/include/libbb.h busybox.dev/include/libbb.h
+--- busybox.old/include/libbb.h        2007-01-19 22:23:10.000000000 +0100
++++ busybox.dev/include/libbb.h        2007-01-22 13:28:56.000000000 +0100
+@@ -637,6 +637,7 @@
+ extern const char bb_uuenc_tbl_std[];
+ void bb_uuencode(const unsigned char *s, char *store, const int length, const char *tbl);
  
 +typedef enum { HASH_SHA1, HASH_MD5 } hash_algo_t;
-+
- typedef struct _sha1_ctx_t_ {
+ typedef struct sha1_ctx_t {
        uint32_t count[2];
        uint32_t hash[5];
-@@ -542,6 +544,10 @@
+@@ -658,6 +659,8 @@
+ void md5_begin(md5_ctx_t *ctx);
  void md5_hash(const void *data, size_t length, md5_ctx_t *ctx);
  void *md5_end(void *resbuf, md5_ctx_t *ctx);
-+unsigned char *hash_bin_to_hex(unsigned char *hash_value, unsigned char hash_length);
-+int hash_fd(int fd, hash_algo_t hash_algo, uint8_t *hash_value);
++unsigned char *hash_bin_to_hex(unsigned char *hash_value, unsigned hash_length);
 +uint8_t *hash_file(const char *filename, hash_algo_t hash_algo);
-+
- extern uint32_t *bb_crc32_filltable (int endian);
  
- #ifndef RB_POWER_OFF
-diff -ruN busybox-1.2.0-orig/libbb/hash.c busybox-1.2.0-libbb_hash/libbb/hash.c
---- busybox-1.2.0-orig/libbb/hash.c    1970-01-01 01:00:00.000000000 +0100
-+++ busybox-1.2.0-libbb_hash/libbb/hash.c      2006-07-22 17:07:34.000000000 +0200
-@@ -0,0 +1,100 @@
+ uint32_t *crc32_filltable(int endian);
+diff -ur busybox.old/libbb/Kbuild busybox.dev/libbb/Kbuild
+--- busybox.old/libbb/Kbuild   2007-01-19 22:23:06.000000000 +0100
++++ busybox.dev/libbb/Kbuild   2007-01-22 13:29:24.000000000 +0100
+@@ -37,6 +37,7 @@
+ lib-y += get_last_path_component.o
+ lib-y += get_line_from_file.o
+ lib-y += getopt32.o
++lib-y += hash.o
+ lib-y += herror_msg.o
+ lib-y += herror_msg_and_die.o
+ lib-y += human_readable.o
+--- busybox.old/libbb/hash.c   1970-01-01 01:00:00.000000000 +0100
++++ busybox.dev/libbb/hash.c   2007-01-22 13:52:41.000000000 +0100
+@@ -0,0 +1,82 @@
 +/*
 + *  Copyright (C) 2003 Glenn L. McGrath
 + *  Copyright (C) 2003-2004 Erik Andersen
@@ -132,97 +129,68 @@ diff -ruN busybox-1.2.0-orig/libbb/hash.c busybox-1.2.0-libbb_hash/libbb/hash.c
 +
 +#include "busybox.h"
 +
-+unsigned char *hash_bin_to_hex(unsigned char *hash_value, unsigned char hash_length)
++/* This might be useful elsewhere */
++unsigned char *hash_bin_to_hex(unsigned char *hash_value,
++                              unsigned hash_length)
 +{
-+      int x, len, max;
-+      unsigned char *hex_value;
-+
-+      max = (hash_length * 2) + 2;
-+      hex_value = xmalloc(max);
-+      for (x = len = 0; x < hash_length; x++) {
-+              len += snprintf((char*)(hex_value + len), max - len, "%02x", hash_value[x]);
-+      }
-+      return (hex_value);
++      /* xzalloc zero-terminates */
++      char *hex_value = xzalloc((hash_length * 2) + 1);
++      bin2hex(hex_value, (char*)hash_value, hash_length);
++      return hex_value;
 +}
 +
-+int hash_fd(int fd, hash_algo_t hash_algo, uint8_t *hash_value)
++uint8_t *hash_file(const char *filename, hash_algo_t hash_algo)
 +{
-+      int count, result = 0;
++      int src_fd, hash_len, count;
 +      union _ctx_ {
 +              sha1_ctx_t sha1;
 +              md5_ctx_t md5;
 +      } context;
++      uint8_t *hash_value = NULL;
 +      RESERVE_CONFIG_UBUFFER(in_buf, 4096);
-+      void (*update)(const void*, size_t, void*) = NULL;
-+      void (*final)(void*, void*) = NULL;
-+      
-+      // figure specific hash algorithims
++      void (*update)(const void*, size_t, void*);
++      void (*final)(void*, void*);
++
++      src_fd = STDIN_FILENO;
++      if (NOT_LONE_DASH(filename)) {
++              src_fd = open(filename, O_RDONLY);
++              if (src_fd < 0) {
++                      bb_perror_msg("%s", filename);
++                      return NULL;
++              }
++      }
++
++      /* figure specific hash algorithims */
 +      if (hash_algo==HASH_MD5) {
 +              md5_begin(&context.md5);
 +              update = (void (*)(const void*, size_t, void*))md5_hash;
 +              final = (void (*)(void*, void*))md5_end;
++              hash_len = 16;
 +      } else if (hash_algo==HASH_SHA1) {
 +              sha1_begin(&context.sha1);
 +              update = (void (*)(const void*, size_t, void*))sha1_hash;
 +              final = (void (*)(void*, void*))sha1_end;
++              hash_len = 20;
++      } else {
++              bb_error_msg_and_die("algorithm not supported");
 +      }
 +
-+
-+      while (0 < (count = read(fd, in_buf, sizeof in_buf))) {
++      while (0 < (count = safe_read(src_fd, in_buf, 4096))) {
 +              update(in_buf, count, &context);
-+              result += count;
 +      }
 +
 +      if (count == 0) {
-+              final(hash_value, &context);
-+      }
-+      
-+      RELEASE_CONFIG_BUFFER(in_buf);
-+      
-+      return result;
-+}
-+
-+uint8_t *hash_file(const char *filename, hash_algo_t hash_algo)
-+{
-+      int src_fd, hash_len;
-+      RESERVE_CONFIG_UBUFFER(hash_buf, 20);
-+      uint8_t *hash_value = NULL;
-+      
-+      if (ENABLE_MD5SUM && hash_algo==HASH_MD5) {
-+              hash_len = 16;
-+      } else if (ENABLE_SHA1SUM && hash_algo==HASH_SHA1) {
-+              hash_len = 20;
-+      } else {
-+              bb_error_msg_and_die("algotithm not supported");
++              final(in_buf, &context);
++              hash_value = hash_bin_to_hex(in_buf, hash_len);
 +      }
 +
-+      if (strcmp(filename, "-") == 0) {
-+              src_fd = STDIN_FILENO;
-+      } else if (0 > (src_fd = open(filename, O_RDONLY))) {
-+              bb_perror_msg("%s", filename);
-+              return NULL;
-+      }
++      RELEASE_CONFIG_BUFFER(in_buf);
 +
-+      if (hash_fd(src_fd, hash_algo, hash_buf) > 0) {
-+              hash_value = hash_bin_to_hex(hash_buf, hash_len);
-+      }
-+      
 +      if (src_fd != STDIN_FILENO) {
 +              close(src_fd);
 +      }
-+      
-+      RELEASE_CONFIG_BUFFER(hash_buf);
 +
 +      return hash_value;
 +}
-diff -ruN busybox-1.2.0-orig/libbb/Makefile.in busybox-1.2.0-libbb_hash/libbb/Makefile.in
---- busybox-1.2.0-orig/libbb/Makefile.in       2006-07-01 00:42:08.000000000 +0200
-+++ busybox-1.2.0-libbb_hash/libbb/Makefile.in 2006-07-22 16:51:47.000000000 +0200
-@@ -11,6 +11,7 @@
- LIBBB-n:=
- LIBBB-y:= \
-+      hash.c \
-       bb_asprintf.c ask_confirmation.c change_identity.c chomp.c \
-       compare_string_array.c concat_path_file.c copy_file.c copyfd.c \
-       crc32.c create_icmp_socket.c create_icmp6_socket.c \
++
++