move diag from target/linux/package/ to package/.
[openwrt.git] / package / busybox / Makefile
index 8877c373c151a119664d1f34d374a48741ce4c5c..aac9d21e323aa292d3ada4396a7fafc24f7b056b 100644 (file)
@@ -1,9 +1,44 @@
+# $Id$
+
 include $(TOPDIR)/rules.mk
 
-include ./busybox.mk
+PKG_NAME:=busybox
+PKG_VERSION:=1.1.3
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://www.busybox.net/downloads
+PKG_MD5SUM:=19a0b475169335f17e421cf644616fe7
+PKG_CAT:=bzcat
+
+include $(TOPDIR)/package/rules.mk
+
+define Package/busybox
+SECTION:=base
+CATEGORY:=Base system
+MENU:=1
+DEFAULT:=y
+TITLE:=Core utilities for embedded Linux
+DESCRIPTION:=The Swiss Army Knife of embedded Linux. \\\
+It slices, it dices, it makes Julian Fries.
+URL:=http://busybox.net/
+CONFIG:=\\\
+       menu "Configuration" \\\
+               depends on PACKAGE_busybox \\\
+               source "$(SOURCE)/config/Config.in" \\\
+       endmenu
+endef
+
+define Build/Configure
+       $(SCRIPT_DIR)/gen_busybox_config.pl $(TOPDIR)/.config > $(PKG_BUILD_DIR)/.config
+       yes '' | $(MAKE) CC=$(TARGET_CC) CROSS="$(TARGET_CROSS)" -C $(PKG_BUILD_DIR) oldconfig
+endef
+
+define Package/busybox/install
+       $(MAKE) CC=$(TARGET_CC) CROSS="$(TARGET_CROSS)" PREFIX="$(1)" \
+               EXTRA_CFLAGS="$(TARGET_CFLAGS)" -C $(PKG_BUILD_DIR) install
+       -rm -rf $(1)/lib64
+endef
 
-source: busybox-source
-prepare: $(BUSYBOX_DIR)/.unpacked
-compile: $(BUSYBOX_DIR)/busybox
-install: busybox
-clean: busybox-dirclean
+$(eval $(call BuildPackage,busybox))