uboot-lantiq: add packages for Lantiq EASY80920
[openwrt.git] / package / boot / uboot-lantiq / Makefile
index b71b1e8578ab6276589ff10ff0fafa5399d63e84..a021ab03934eabed3ab5b8fb2c126c46a4389352 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=u-boot
-PKG_VERSION:=2013.01
+PKG_VERSION:=2013.10
 PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
@@ -16,7 +16,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
        http://mirror2.openwrt.org/sources \
        ftp://ftp.denx.de/pub/u-boot
-PKG_MD5SUM:=e58a8a7f78972248190d83de0dc362ce
+PKG_MD5SUM:=a076a044b64371edc52f7e562b13f6b2
 PKG_TARGETS:=bin
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
@@ -63,10 +63,53 @@ define uboot/gigasx76x_nor
   SOC:=danube
 endef
 
+define uboot/easy50712_ram
+  TITLE:=U-Boot for Lantiq EASY50712 (RAM)
+  SOC:=danube
+  DDR_SETTINGS:=board/lantiq/easy50712/ddr_settings.h
+endef
+
+define uboot/easy50712_nor
+  TITLE:=U-Boot for Lantiq EASY50712 (NOR)
+  SOC:=danube
+endef
+
+define uboot/easy50712_norspl
+  TITLE:=U-Boot for Lantiq EASY50712 (NOR SPL)
+  SOC:=danube
+  IMAGE:=u-boot.ltq.lzo.norspl
+endef
+
+define uboot/easy80920_ram
+  TITLE:=U-Boot for Lantiq EASY80920 (RAM)
+  SOC:=vr9
+  DDR_SETTINGS:=board/lantiq/easy80920/ddr_settings.h
+endef
+
+define uboot/easy80920_nor
+  TITLE:=U-Boot for Lantiq EASY80920 (NOR)
+  SOC:=vr9
+endef
+
+define uboot/easy80920_norspl
+  TITLE:=U-Boot for Lantiq EASY80920 (NOR SPL)
+  SOC:=vr9
+  IMAGE:=u-boot.ltq.lzo.norspl
+endef
+
+define uboot/easy80920_sfspl
+  TITLE:=U-Boot for Lantiq EASY80920 (SPI SPL)
+  SOC:=vr9
+  IMAGE:=u-boot.ltq.lzo.sfspl
+endef
+
+
 UBOOTS:= \
        arv4519pw_ram arv4519pw_nor \
        arv7518pw_ram arv7518pw_nor \
-       gigasx76x_ram gigasx76x_nor
+       gigasx76x_ram gigasx76x_nor \
+       easy50712_ram easy50712_nor easy50712_norspl \
+       easy80920_ram easy80920_nor easy80920_norspl easy80920_sfspl
 
 define Package/uboot/template
 define Package/uboot-lantiq-$(1)