enable netifd by default and add its config variable to PKG_CONFIG_DEPENDS in a few...
[openwrt.git] / package / 6in4 / Makefile
index 289d28ee3f32234ec53ee6a5f69873097bb403ed..c2fcc3ba1c6578af6692da3e35372fee28393780 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,9 +8,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6in4
-PKG_VERSION:=4
+PKG_VERSION:=10
 PKG_RELEASE:=1
 
+PKG_CONFIG_DEPENDS:=CONFIG_PACKAGE_netifd
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/6in4
@@ -18,6 +20,7 @@ define Package/6in4
   CATEGORY:=IPv6
   DEPENDS:=+ip +kmod-ipv6 +kmod-sit
   TITLE:=IPv6-in-IPv4 configuration support
+  MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
   PKGARCH:=all
 endef
 
@@ -33,11 +36,20 @@ endef
 define Build/Configure
 endef
 
-define Package/6in4/install
-       $(INSTALL_DIR) $(1)/lib/network
-       $(INSTALL_DATA) ./files/6in4.sh $(1)/lib/network/6in4.sh
+ifneq ($(CONFIG_PACKAGE_netifd),)
+  define Package/6in4/install
+       $(INSTALL_DIR) $(1)/lib/netifd/proto
+       $(INSTALL_BIN) ./files/6in4.sh $(1)/lib/netifd/proto/6in4.sh
        $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
        $(INSTALL_DATA) ./files/6in4.hotplug $(1)/etc/hotplug.d/iface/90-6in4
-endef
+  endef
+else
+  define Package/6in4/install
+       $(INSTALL_DIR) $(1)/lib/network
+       $(INSTALL_DATA) ./files.old/6in4.sh $(1)/lib/network/6in4.sh
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+       $(INSTALL_DATA) ./files.old/6in4.hotplug $(1)/etc/hotplug.d/iface/90-6in4
+  endef
+endif
 
 $(eval $(call BuildPackage,6in4))