add ppp/pppoe to kernel config, remove some compile warnings (cli->local_irq_disable)
[openwrt.git] / openwrt / target / linux / linux-2.6 / patches / brcm / 001-bcm947xx.patch
index 0d69114d39cff524380457bec402afb1ffbab48a..649028d89fa6ef27432c123f182e88a0e16da05e 100644 (file)
@@ -12587,7 +12587,7 @@ diff -Nur linux-2.6.12.5/arch/mips/bcm947xx/prom.c linux-2.6.12.5-brcm/arch/mips
 +}
 diff -Nur linux-2.6.12.5/arch/mips/bcm947xx/setup.c linux-2.6.12.5-brcm/arch/mips/bcm947xx/setup.c
 --- linux-2.6.12.5/arch/mips/bcm947xx/setup.c  1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.6.12.5-brcm/arch/mips/bcm947xx/setup.c     2005-08-28 16:57:28.317825624 +0200
++++ linux-2.6.12.5-brcm/arch/mips/bcm947xx/setup.c     2005-09-11 01:36:10.217667456 +0200
 @@ -0,0 +1,127 @@
 +/*
 + *  Copyright (C) 2004 Florian Schirmer (jolt@tuxbox.org)
@@ -12684,7 +12684,7 @@ diff -Nur linux-2.6.12.5/arch/mips/bcm947xx/setup.c linux-2.6.12.5-brcm/arch/mip
 +static void bcm47xx_machine_restart(char *command)
 +{
 +      /* Set the watchdog timer to reset immediately */
-+      cli();
++      local_irq_disable();
 +      sb_watchdog(sbh, 1);
 +      while (1);
 +}
@@ -12692,7 +12692,7 @@ diff -Nur linux-2.6.12.5/arch/mips/bcm947xx/setup.c linux-2.6.12.5-brcm/arch/mip
 +static void bcm47xx_machine_halt(void)
 +{
 +      /* Disable interrupts and watchdog and spin forever */
-+      cli();
++      local_irq_disable();
 +      sb_watchdog(sbh, 0);
 +      while (1);
 +}
@@ -13059,7 +13059,7 @@ diff -Nur linux-2.6.12.5/drivers/mtd/maps/Makefile linux-2.6.12.5-brcm/drivers/m
  obj-$(CONFIG_MTD_SBC_GXX)     += sbc_gxx.o
 diff -Nur linux-2.6.12.5/drivers/mtd/maps/bcm47xx-flash.c linux-2.6.12.5-brcm/drivers/mtd/maps/bcm47xx-flash.c
 --- linux-2.6.12.5/drivers/mtd/maps/bcm47xx-flash.c    1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.6.12.5-brcm/drivers/mtd/maps/bcm47xx-flash.c       2005-09-04 04:50:19.246786848 +0200
++++ linux-2.6.12.5-brcm/drivers/mtd/maps/bcm47xx-flash.c       2005-09-10 22:23:03.178338008 +0200
 @@ -0,0 +1,249 @@
 +/*
 + *  Copyright (C) 2004 Florian Schirmer (jolt@tuxbox.org)
@@ -13220,13 +13220,15 @@ diff -Nur linux-2.6.12.5/drivers/mtd/maps/bcm47xx-flash.c linux-2.6.12.5-brcm/dr
 +      bcm947xx_parts[3].size   = NVRAM_SIZE;
 +
 +      /* Size linux (kernel and rootfs) */
-+      bcm947xx_parts[1].offset = bcm947xx_parts[0].size + bcm947xx_parts[3].size;
-+      bcm947xx_parts[1].size   = size - NVRAM_SIZE - bcm947xx_parts[0].size - bcm947xx_parts[3].size;
++      /* do not count the elf loader, which is on one sector */
++      bcm947xx_parts[1].offset = bcm947xx_parts[0].size + bcm947xx_parts[3].size + mtd->erasesize;
++      bcm947xx_parts[1].size   = size - NVRAM_SIZE - bcm947xx_parts[0].size - 
++              bcm947xx_parts[3].size - mtd->erasesize;
 +
 +      /* Find and size rootfs */
 +      if (find_root(mtd,size,&bcm947xx_parts[2])==0) {
 +              /* entirely jffs2 */
-+              bcm947xx_parts[2].size = bcm947xx_parts[3].offset - bcm947xx_parts[2].offset
++              bcm947xx_parts[2].size = size - bcm947xx_parts[2].offset - NVRAM_SIZE
 +              bcm947xx_parts[4].name = NULL;
 +      } else {
 +              /* legacy setup */
@@ -13235,10 +13237,8 @@ diff -Nur linux-2.6.12.5/drivers/mtd/maps/bcm47xx-flash.c linux-2.6.12.5-brcm/dr
 +              if ((bcm947xx_parts[4].offset % mtd->erasesize) > 0) {
 +                      bcm947xx_parts[4].offset += mtd->erasesize - 
 +                              (bcm947xx_parts[4].offset % mtd->erasesize);
-+                      bcm947xx_parts[4].size = size - NVRAM_SIZE - bcm947xx_parts[4].offset;
-+              } else {
-+                      bcm947xx_parts[4].size = bcm947xx_parts[3].offset - bcm947xx_parts[4].offset;
 +              }
++              bcm947xx_parts[4].size = size - NVRAM_SIZE - bcm947xx_parts[4].offset;
 +      }
 +
 +      return bcm947xx_parts;