build: include the cpu type as part of the toolchain/target directory name
[openwrt.git] / include / target.mk
index c3b4c5245933793a9ce6ec31608cf3a9082441a7..4e7fdf7b90a8a260e351d1307c1df7c7871ad358 100644 (file)
@@ -254,6 +254,7 @@ define BuildTargets/DumpCurrent
         echo 'Target-Features: $(FEATURES)'; \
         echo 'Target-Depends: $(DEPENDS)'; \
         echo 'Target-Optimization: $(if $(CFLAGS),$(CFLAGS),$(DEFAULT_CFLAGS))'; \
+        echo 'CPU-Type: $(CPU_TYPE)$(if $(CPU_SUBTYPE),+$(CPU_SUBTYPE))'; \
         echo 'Linux-Version: $(LINUX_VERSION)'; \
         echo 'Linux-Release: $(LINUX_RELEASE)'; \
         echo 'Linux-Kernel-Arch: $(LINUX_KARCH)'; \