add quotes to ipkg name in the rebuild check
[openwrt.git] / include / package.mk
index 42ffcfbb3ce33b2f9141ac056f6427d64572d5bb..ef1fc48ec83dd6f9a514bce1d5b6decc6e3a8c1c 100644 (file)
@@ -237,14 +237,16 @@ define BuildPackage
   $$(eval $$(call Build/DefaultTargets,$(1)))
 
   ifneq ($$(CONFIG_PACKAGE_$(1)),)
-    ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install $$(IPKG_$(1)) $(PKG_BUILD_DIR)),$$(IPKG_$(1)))
-      _INFO+=$(subst $(TOPDIR)/,,$$(IPKG_$(1)))
-      $(PKG_BUILD_DIR)/.built: package-rebuild
-    endif
-
     ifneq ($(MAKECMDGOALS),prereq)
-      ifneq ($$(_INFO),)
-        $$(info Rebuilding $$(_INFO))
+      ifneq ($(DUMP),1)
+        ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install '$$(IPKG_$(1))' '$(PKG_BUILD_DIR)'),$$(IPKG_$(1)))
+          _INFO+=$(subst $(TOPDIR)/,,$$(IPKG_$(1)))
+          $(PKG_BUILD_DIR)/.built: package-rebuild
+        endif
+
+        ifneq ($$(_INFO),)
+          $$(info Rebuilding $$(_INFO))
+        endif
       endif
     endif
   endif