avoid a race condition that might lead to dnsmasq reading an empty resolv.conf (...
[openwrt.git] / include / kernel-defaults.mk
index 84030a6d2dc0677ba2a56b7c80c0acc943fa948a..1bd6b427adffb4cebbfd9c416ec896f6bf0d9216 100644 (file)
@@ -33,7 +33,7 @@ KERNEL_MAKEOPTS := -C $(LINUX_DIR) \
 # defined in quilt.mk
 Kernel/Patch:=$(Kernel/Patch/Default)
 define Kernel/Prepare/Default
-       bzcat $(DL_DIR)/$(LINUX_SOURCE) | tar -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS)
+       bzcat $(DL_DIR)/$(LINUX_SOURCE) | $(TAR) -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS)
        $(Kernel/Patch)
 endef
 
@@ -47,9 +47,9 @@ define Kernel/Configure/2.6
 endef
 define Kernel/Configure/Default
        @if [ -f "./config/profile-$(PROFILE)" ]; then \
-               $(SCRIPT_DIR)/config.pl '+' $(GENERIC_PLATFORM_DIR)/config-template '+' $(LINUX_CONFIG) ./config/profile-$(PROFILE) > $(LINUX_DIR)/.config; \
+               $(SCRIPT_DIR)/config.pl '+' $(GENERIC_LINUX_CONFIG) '+' $(LINUX_CONFIG) ./config/profile-$(PROFILE) > $(LINUX_DIR)/.config; \
        else \
-               $(SCRIPT_DIR)/config.pl '+' $(GENERIC_PLATFORM_DIR)/config-template $(LINUX_CONFIG) > $(LINUX_DIR)/.config; \
+               $(SCRIPT_DIR)/config.pl '+' $(GENERIC_LINUX_CONFIG) $(LINUX_CONFIG) > $(LINUX_DIR)/.config; \
        fi
        $(call Kernel/Configure/$(KERNEL))
        rm -rf $(KERNEL_BUILD_DIR)/modules