[include] host-build.mk: define a variable HOST_STATIC_LINKING which is set to "...
[openwrt.git] / include / host-build.mk
index df7d60611ee07fe95cfd497d093c2938f5105344..a8bc79ea67de34648d444644e694539b8d95d219 100644 (file)
@@ -65,6 +65,10 @@ HOST_CONFIGURE_ARGS = \
 
 HOST_CONFIGURE_CMD = ./configure
 
+ifneq ($(HOST_OS),Darwin)
+  HOST_STATIC_LINKING = -static
+endif
+
 define Host/Configure/Default
        (cd $(HOST_BUILD_DIR)/$(3); \
                if [ -x configure ]; then \
@@ -113,6 +117,7 @@ define Download/default
   SUBDIR:=$(PKG_SOURCE_SUBDIR)
   VERSION:=$(PKG_SOURCE_VERSION)
   MD5SUM:=$(PKG_MD5SUM)
+  MIRROR_MD5SUM:=$(PKG_MIRROR_MD5SUM)
 endef
 
 define Host/Exports/Default