remove unused wget menuconfig option; make the package autorebuild optional (but...
[openwrt.git] / Makefile
index f93b008033f0f323502c4a73849e489625e46c8c..84508b1ffcfb3adf40d8ba891b02672af5b3d2aa 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -38,7 +38,7 @@ endif
 endif
 export OPENWRTVERSION
 
-all:
+all: world
 
 .pkginfo: FORCE
 ifneq ($(shell ./scripts/timestamp.pl -p .pkginfo package Makefile),.pkginfo)
@@ -61,23 +61,45 @@ scripts/config/mconf: .config.in
 scripts/config/conf: .config.in
        $(MAKE) -C scripts/config conf
 
-menuconfig: scripts/config/mconf
+config: scripts/config/conf FORCE
        $< Config.in
 
-config: scripts/config/conf
+defdconfig: scripts/config/conf FORCE
+       $< -d Config.in
+
+oldconfig: scripts/config/conf FORCE
+       $< -o Config.in
+
+menuconfig: scripts/config/mconf FORCE
        $< Config.in
 
-config-clean:
+config-clean: FORCE
        $(MAKE) -C scripts/config clean
 
-package/%: .pkginfo
+package/%: .pkginfo FORCE
        $(MAKE) -C package $(patsubst package/%,%,$@)
 
-target/%: .pkginfo
+target/%: .pkginfo FORCE
        $(MAKE) -C target $(patsubst target/%,%,$@)
 
-toolchain/%:
+toolchain/%: FORCE
        $(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
 
+world: FORCE
+       $(MAKE) toolchain/install
+       $(MAKE) target/compile
+       $(MAKE) package/compile
+       $(MAKE) package/install
+       $(MAKE) target/install
+
+clean: FORCE
+       rm -rf build_* bin
+
+dirclean: clean FORCE
+       rm -rf staging_dir_* toolchain_build_*
+
+distclean: dirclean FORCE
+       rm -rf .* dl
+
 .PHONY: FORCE
 FORCE: