fix ipsec compile (FIXME: move DESTDIR to build template?)
[openwrt.git] / Makefile
index dae32830c28b8243d02f6a31638551e3c4fa0558..10652c07a33d56f76c0681df9223df9dcfc56a81 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -26,6 +26,7 @@ RELEASE:=Kamikaze
 #--------------------------------------------------------------
 TOPDIR=${shell pwd}
 export TOPDIR
+include $(TOPDIR)/include/verbose.mk
 
 OPENWRTVERSION:=$(RELEASE)
 ifneq ($(VERSION),)
@@ -45,7 +46,7 @@ ifneq ($(shell ./scripts/timestamp.pl -p .pkginfo package Makefile),.pkginfo)
        @echo Collecting package info...
        @-for dir in package/*/; do \
                echo Source-Makefile: $${dir}Makefile; \
-               $(MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
+               $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
        done > $@
 endif
 
@@ -86,9 +87,16 @@ target/%: .pkginfo FORCE
 toolchain/%: FORCE
        $(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
 
-world: ./scripts/config/conf FORCE
-       touch .config
+.config: ./scripts/config/conf FORCE
+       @[ -f .config ] || $(MAKE) menuconfig
        $< -D .config Config.in >/dev/null 2>/dev/null
+
+download: .config FORCE
+       $(MAKE) toolchain/download
+       $(MAKE) package/download
+       $(MAKE) target/download
+
+world: .config FORCE
        $(MAKE) toolchain/install
        $(MAKE) target/compile
        $(MAKE) package/compile
@@ -98,10 +106,10 @@ world: ./scripts/config/conf FORCE
 clean: FORCE
        rm -rf build_* bin
 
-dirclean: clean FORCE
+dirclean: clean
        rm -rf staging_dir_* toolchain_build_*
 
-distclean: dirclean FORCE
+distclean: dirclean config-clean
        rm -rf dl .*config* .pkg*
 
 .PHONY: FORCE