diff options
author | florian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73> | 2007-07-19 12:09:52 +0000 |
---|---|---|
committer | florian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73> | 2007-07-19 12:09:52 +0000 |
commit | 8119784b65dedfdcfc9f189508c8f43d7fa94513 (patch) | |
tree | 8585af18947821a254a995e1a8692f78fc8435bf | |
parent | 8677fb58f75727df6b814f49e42a5267ae3a453f (diff) |
Add optionnal support for a BUILD_DIR suffix (#2057)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8050 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r-- | Config.in | 7 | ||||
-rw-r--r-- | rules.mk | 3 |
2 files changed, 9 insertions, 1 deletions
@@ -123,6 +123,13 @@ config SOURCE_FEEDS help Separate sources with spaces : " " +config BUILD_SUFFIX + string + prompt "Build suffix to append to the BUILD_DIR variable" if BUILDOPTS + default "" + help + Build suffix to append to the BUILD_DIR variable, i.e: build_dir_suffix + source "toolchain/Config.in" source "target/imagebuilder/Config.in" source "target/sdk/Config.in" @@ -14,6 +14,7 @@ export SHELL=/usr/bin/env bash -c '. $(TOPDIR)/include/shell.sh; eval "$$2"' -- ARCH:=$(strip $(subst ",, $(CONFIG_ARCH))) TARGET_OPTIMIZATION:=$(strip $(subst ",, $(CONFIG_TARGET_OPTIMIZATION))) +BUILD_DIR_SUFFIX:=$(strip $(subst ",, $(CONFIG_BUILD_SUFFIX))) WGET:=$(strip $(subst ",, $(CONFIG_WGET))) #"))"))")) # fix vim's broken syntax highlighting @@ -30,7 +31,7 @@ STAGING_DIR:=$(TOPDIR)/staging_dir_$(ARCH) BIN_DIR:=$(TOPDIR)/bin PACKAGE_DIR:=$(BIN_DIR)/packages IPKG_TARGET_DIR:=$(PACKAGE_DIR) -BUILD_DIR:=$(TOPDIR)/build_$(ARCH) +BUILD_DIR:=$(TOPDIR)/build_$(ARCH)$(BUILD_DIR_SUFFIX) TMP_DIR:=$(TOPDIR)/tmp STAMP_DIR:=$(BUILD_DIR)/stamp TARGET_DIR:=$(BUILD_DIR)/root |