]> git.enpas.org Git - openwrt.git/commitdiff
[package] openssl: fix syntax error in OpenWrt Makefile
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 18 Jan 2012 14:48:16 +0000 (14:48 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 18 Jan 2012 14:48:16 +0000 (14:48 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29774 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/openssl/Makefile

index 48e8a427f6983a7f53b86c0917135414f1c2b1ce..67f643c92f284db0a60a5718f6422ef8c9382566 100644 (file)
@@ -142,7 +142,7 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc $(1)/usr/lib/pkgconfig/
-       $(if $(TARGET_LDFLAGS),$(SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc)
+       [ -n "$(TARGET_LDFLAGS)" ] && $(SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc || true
 endef
 
 define Package/libopenssl/install