]> git.enpas.org Git - openwrt.git/blobdiff - target/linux/imx6/Makefile
kernel: update kernel 3.10 to 3.10.24
[openwrt.git] / target / linux / imx6 / Makefile
index b26e4818c1b2640e5d7756e54c467704cc2dad9e..794a709b7738e319dc76d6b131e5381f448e4649 100644 (file)
@@ -9,17 +9,15 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=imx6
 BOARDNAME:=Freescale i.MX 6 Series
-FEATURES:=audio display gpio pcie usb usbgadget squashfs targz
-CFLAGS:=-Os -pipe -mtune=cortex-a9 -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
+FEATURES:=audio display gpio pcie usb usbgadget squashfs targz ubifs
+CPU_TYPE:=cortex-a9
+CPU_SUBTYPE:=vfpv3
 MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.24
 
 include $(INCLUDE_DIR)/target.mk
 
 KERNELNAME:="zImage dtbs"
 
-DEFAULT_PACKAGES += \
-       kmod-usb-chipidea kmod-usb-mxs-phy uboot-envtools
-
 $(eval $(call BuildTarget))