]> git.enpas.org Git - openwrt.git/blobdiff - target/linux/gemini/Makefile
build: unify target independent optimization options
[openwrt.git] / target / linux / gemini / Makefile
index b83bc4d5d2e6f0709ec51140ebc081a4727f0bb3..e1586d138f4c12d69a2446c9e8f1e7599e9746c1 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,10 +9,13 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=gemini
 BOARDNAME:=Cortina Systems CS351x
-FEATURES:=jffs2 broken
-CFLAGS:=-Os -pipe -march=armv4 -mtune=arm9tdmi -funit-at-a-time
+FEATURES:=squashfs pci
+CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.30-rc6
+LINUX_VERSION:=3.9.11
+
+KERNELNAME:="zImage"
 
 include $(INCLUDE_DIR)/target.mk