]> git.enpas.org Git - openwrt.git/blobdiff - target/linux/ar71xx/Makefile
kernel: update 3.10 to 3.10.2
[openwrt.git] / target / linux / ar71xx / Makefile
index 30610f8c6f4d32d75bb5099c27512a5d8e1e1cb3..43ee26173647af91efe7ce8bb8970576f31699b5 100644 (file)
@@ -9,16 +9,17 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=ar71xx
 BOARDNAME:=Atheros AR7xxx/AR9xxx
-FEATURES:=squashfs jffs2 targz
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+FEATURES:=squashfs targz mips16
+CFLAGS:=-Os -pipe -mips32r2 -mtune=34kc -fno-caller-saves -mno-branch-likely
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=3.2.12
+LINUX_VERSION:=3.10.2
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
-       kmod-leds-gpio kmod-gpio-button-hotplug kmod-wdt-ath79 swconfig \
+       kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
+       kmod-ledtrig-default-on kmod-ledtrig-timer kmod-ledtrig-netdev \
        kmod-ath9k wpad-mini uboot-envtools
 
 define Target/Description