]> git.enpas.org Git - openwrt.git/blobdiff - include/host.mk
fixes for a few build errors on osx without fink
[openwrt.git] / include / host.mk
index 4a434711c3c8649c259cb3826aacb53fd9547c8d..8b4ce3d24b9101ebe1ab1603da33a75decd56273 100644 (file)
@@ -9,6 +9,8 @@ include $(TMP_DIR)/.host.mk
 
 export TAR
 
+ifneq ($(__host_inc),1)
+__host_inc:=1
 $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
        @mkdir -p $(TMP_DIR)
        @( \
@@ -32,3 +34,10 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
                echo "BASH:=$(shell which bash)" >> $@; \
        )
 
+endif
+
+ifeq ($(HOST_OS),Linux)
+  XARGS:=xargs -r
+else
+  XARGS:=xargs
+endif